Watching 'websdr' using Opera or Slimjet browser

Hello there from Canberra, Australia.

Another of my interests is amateur radio. Currently ‘websdr’ provides an opportunity to listen to amateur stations that I cannot hear in Canberra. There are websdr installations world-wide, but I frequently pop up on a semi-local one in Sydney (300Km away). However I can only get by by switching to Firefox for my browser. That’s okay … but I mostly use Opera and/or Slimjet. Neither of these browsers seems to be able recover the audio which may be either java or html5. I have cruised the internet looking for an extension (?) to enable this … as I also like to look at youtube videos too! Some of these are silent (for me!).

Does anyone know how to bring my broswer into the current century??

Ta for any help.

Riccardo

PS previous advice from this channel has enabled me to continue with EndeavourOS … installing amateur radio programs … and also providing a cheat-sheet to assist other newcomers to use the AUR to cinorporate programs into the standard EndeavourOS. Thanks again.

An educated guess: did you add opera-ffmpeg-codecs?

https://www.archlinux.org/packages/community/x86_64/opera-ffmpeg-codecs/

It could help I hope.

Thanks for the reply Fred. I did make sure that I downloaded the file you mentioned … and I rebooted after that. Unfortunately, there was no improvement. I can get audio from several of my youtube interests (narrowboats, don’t ask) … but it remains silent on the Sydney websdr. It’s really no big issue … but it is an annoyance! Any additional suggestions? How do I ensure tht the ffmpeg codecs are ON and in use??

R

Fred

One further point which may help with your reply: On the website I do get the waterfall as normal … but it lacks any recovered audio!! I’ve looked at settings, etc. … and also extensions … but there seems to be nothing there for me!

R

Hello @riccardo I’m not exactly sure what your issue is. You are not getting sound on Opera? I have tried some websdr and it works for me on Opera and Firefox but i am not able to go to every site. I went here and tried it and some sites are not accessible but the sound works on the ones i can access.

https://skywavelinux.com/best-sdrservers.html

Here is one i listened to from Australia.

Hello Rick

Thanks for your input. I know of Skywave Linux and have used it once or twice. I have EndeavourOS installed on this desktop … and I have added Opera to my list of browsers. Firefox is good but a little too bloated for my liking. I have also added Slimjet … !

Opera works well for me on many sites … including youtube. However, when I load this website:

http://websdr.mwrs.org.au:8901

and attempt to listen, I get a mute response. The waterfall is normal, the site shows HTML5 is in use … but there is no audio. I tried loading ffmpeg codecs … as suggested … but no change.

If I go back to Firefox then it works as it should. Hardware seems okay. Opera remains stubbornly silent. The Opera I use is from EndeavourOS reps and is up-to-date. IT is:- Version:63.0.3368.88

Further help would be appreciated.

R

I will try it now. It say’s the following and i am only getting waterfall and noise on firefox. It is running on html5.

Note: you need both Java and JavaScript enabled for this page to work properly. If you don’t hear anything, probably Java is disabled or its version is too old (i.e., pre-1.4.2).

I think this is only if you are using java as opposed to html5. At any rate this site is not giving me anything on Firefox because it doesn’t seem to be broadcasting? On opera it is definitely not working. It is working on Firefox but I’m only getting waterfall and noise.

Rick

There’s a couple of stations on 7.110 … and I can hear (on my QRP rig) one side. The waterfall shows the station I cannot hear. That’s band conditions for this time on 40 metres.

R

Okay so i get nothing on Opera. My suggestion is you use Vivaldi as it works like firefox. I have the waterfall and noise on both Firefox and Vivaldi but not Opera.

You can install Vivaldi with yay.
yay -S vivaldi

At 40 meters i have it on Firefox only. No sound yet on Vivladi but i have waterfall. Okay i figured it out! I now have sound on Vivaldi

Rick

Did a quick install of vivaldi and it works 100%!! Thanks for the suggestion. Still miffed about why Opera is silent… but now I have a slim alternative to Firefox.

R

Okay just so you know because it is HTML5 it is using flash so what you have to do is look at my screen shot and click on the i in the url window. Then allow flash because it’s blocking it. Then go into site settings and add the particular site you’re on. Then it should not block it each time. You can add other sites the same way. This can be done maybe in Opera too but it’s easy here in Vivaldi. I have both adobe flash plugin installed and pepperflash. One is a NPAPI and the other is PPAPI flash plug ins. If you don’t have them installed then install pamac which is the GUI for pacman and it does the AUR also. You can use yay to install pamac. Or you can use yay to install the flash but you need to know the exact name of the package or it won’t find it.

Does this help?

Rick

I did as you suggested … and enabling flash has produced sound!! Thanks heaps! I think I will keep Vivaldi installed … because I don’t want to be enabling sites 1 by 1! Thanks again for your help.

R

You can do the same on Opera here but i think you have to go into settings to get at the flash settings and it may or may not work. Like i say these guys are trying to get rid of flash but personally i prefer it over Googles Webm.

@riccardo I am able to make it work on Opera also but not as easy. Most browsers are set to block flash so you’ll have to do this most of the time and if you add the site it won’t block it. A big welcome to Endeavour.