Warning: package `mesa` may prevent boot! (SOLVED)

On my laptop with hybrid Intel and Radeon graphics, upgrade to mesa 20.0.7-1 made the system unable to boot.
Previous version mesa 20.0.6-2 boots OK.

One way to workaround an unbootable system is to use TTY while trying to boot:

  • press Ctrl-Alt-F2
  • login normally using the TTY terminal
  • commands:
    sudo pacman -S --needed downgrade
    downgrade mesa     # select previous version 20.0.6-2

You may need to downgrade also mesa-vdpau, but unfortunately I couldn’t test that here.

Note: if your system boots normally with the latest mesa, then you need to do nothing.

4 Likes

Thanks for the heads up!

1 Like

idd, here also not booted, standard it boots in tty, no worries :wink: but i3wm didnt start

So I don’t know if this is related… it I just ran an update (kde) and I can log in, but after 5 seconds screen goes black, but I can still move my cursor around.

Any ideas?

I’ve got a MacBook air from 2013

It might be related.

Check what update caused the issue. You can do that e.g. by installing package pahis and run that to show your latest updates.

If mesa seems to be the cause, then downgrade mesa and see it it helps.

1 Like

This worked, thank you.

1 Like

mesa 20.0.7-2 hit the repo, I didn’t have the problem in the first place, but considering the speed of the update, it might be solved.

2 Likes

Yep @Bryanpwo I just upgraded to mesa 20.0.7-2 and the problem is gone.

1 Like

I can no longer login after update, system goes dark, sometimes can’t even type my login, or my screen just freezes. Recovery mode works fine and I can boot to command line. However I can’t run pacman -Syu. Gives me a bunch of errors, almost like I can’t connect to the internet or something.

The systems seems to be running in the background, because I’m able to stream music from my Plex server. Streaming video doesn’t work and crashes Plex on my TV. Not on my phone though.

You might have to downgrade first, reboot then upgrade since the fixed version is already out.

Doesn’t let me downgrade either. "Error: failed retrieving files… says that the url or servers are invalid.

Refresh mirrorlist?

1 Like

How do I do that?

I managed to get into tty without recovery mode and was able to run “downgrade needed”. Now the login loops back to the SDDM login screen.

Some progress, I guess.

Edit: never mind pacman -Syy was the right command. Thanks for the tip! Command worked and I was able to run pacman -Syu after that. Alot of graphics drivers got updated and system booted fine after restart.

1 Like

Here the bug report which leads to mesa 20.0.7-2 update: https://bugs.archlinux.org/task/66666

1 Like

Maybe I’m a bit hasty, but does anyone else have problems with Windows programs installed in a Wine prefix after the mesa update?