Warning from reflector-simple

I’m trying to update but reflector-simple says that I would change some settings. I tried to select my country’s repo from its .config file, but a message raises saying that there’s no repository.
Than, when I try to update with pacman -Syu, it prints to screen there is a SSL certificate problem, so it’s impossibile to reach the archlinux.mirror.server24.net repo.
Any solution?

Comment out that mirror and try again.
Alternatively try program rate-mirrors. If it is not installed, install it if possible.


Maybe because I’m not an expert, but I nothing happens. I installed rate-mirrors but trying some commands does not produce any particular result.

Where I have to do it? I didn’t found anything into the .config file…

Please post the config file and we can show you.

in /etc/pacman.d/mirrorlist

1 Like

Commenting out a mirror in /etc/pacman.d/mirrorlist

Add character # as the character on the line that has the mirror. For example:

Server = http://ftp.halifax.rwth-aachen.de/archlinux/$repo/os/$arch


# Server = http://ftp.halifax.rwth-aachen.de/archlinux/$repo/os/$arch

Example usage of rate-mirrors

rate-mirrors --protocol https arch --max-delay 3600 | sudo tee /etc/pacman.d/mirrorlist

I agree with @manuel , try rate-mirrors.

I find it to be the easiest, simplest, and most reliable way to get a really fast mirrorlist. This program is really an example of finely designed piece of software that follows the Unix philosophy: it has a simple and standardised interface, it does one thing and it does it well.

And it’s written in Rust, so you get additional hipster points when you use it. :bearded_person:t4: :crab:

Done as you said but the problem persist.
But… why commenting that line? Isn’t it an exclusion?

After comment the mirror, launching the command miss that specific mirror as specified in the first post.

There is no need to comment out anything.


sudo cp /etc/pacman.d/mirrorlist /etc/pacman.d/mirrorlist.backup

Followed by

rate-mirrors arch | sudo tee /etc/pacman.d/mirrorlist

And finally

sudo pacman -Syyu

Ok! Now it works! Thank you so much! I was stucked to download every kind of stuff! What cause issues like that?

1 Like

Something was wrong with one of the mirrors. This happens from time to time. Not your fault.

There is still a problem… reflector-simple doesn’t find any mirror…

Is there a reason why you must use reflector-simple? It’s simply terrible, no pun intended. rate-mirrors does everything for you. Just do the three steps in my reply above every time you have a problem with mirrors and forget everything else.

1 Like

I don’t use reflect-simple. The fact is when I use the Welcome app for upgrading arch mirrors it does anything alone. Since few days ago, I was ignoring its existence…

This is just my opinion, of course, but in your place, I would continue to ignore the existence of the Welcome app. Personally, I see no use for it. The way I update the mirrors is in the terminal, like I showed you above.

1 Like