Warning: ark-22.04.2-1 is up to date

I don’t feel like I see anything over at
https://wiki.archlinux.org/title/pacman, or on this forum that I thought could tell about handling this warning.

While in root I had done

sudo pacman -S ark --needed

I’m trying to unzip and install a download which turned out to be MIME type: application/x-executable. It doesn’t do anything.

I decided I should prob do,

pacman -S ark p7zip --needed

, since maybe that is what it needs.

I was met with

warning: ark-22.04.2-1 is up to date – skipping
resolving dependencies…
looking for conflicting packages…

Package (1) New Version Net Change Download Size

extra/p7zip 1:17.04-3 11.21 MiB 2.58 MiB

Total Download Size: 2.58 MiB
Total Installed Size: 11.21 MiB

:: Proceed with installation? [Y/n]

I had seen both things I tried in forum, but nothing about a warning in that thread. I saw another thread where someone got warning, but was told to ignore it.
Do I mess something up if I say yes?, or should I move forward and say yes?

That is just telling you that it is already installed.

Selecting “Yes” would install p7zip but I am not sure how that would help you in this situation or why you think that is needed.

What doesn’t do anything? Are you clicking on it expecting something to happen? Can you share what it is specifically or a link to it so we can inspect it to help you better?

In general, 99% of the time, “installing a download” is going to be the wrong thing to do on an Arch-based Linux distro.

portable qtweb for linux


extraction gave me a license text and the program that doesn’t react. Clicking “trust this executable” didn’t seem to do anything either.

That is an ancient 32-bit elf binary from 2013. Is there a reason you need that specifically?

Trying to get a 9 year old 32-bit browser running on Arch doesn’t seem like much fun. Also, why would you want a browser that old?

Actually, it looks like it is statically linked so it would probably work if you set it executable.

chmod a+x /path/to/QtWeb

Although, I still don’t see why you would want to.

portability. It doesn’t have to be that one specifically. So you think ark works just fine then?, without the (extra?) command?

Yes, ark is an extractor. You can just run it.

trying your command now that I see it.

chmod: cannot access ‘/path/to/QtWeb’: No such file or directory

so I guess the file is too old, or maybe not being maintained.

Why not just download firefox and uncompress it where you want it? Then set the profile to be inside that same directory.

Well, yeah. You have to replace /path/to with the actual location of the file.

I mean…it clearly isn’t being maintained. It was last updated in 2013.

1 Like

I tried it with and without the “/to” part, same result.

No such file or directory

I’ve tried firefox in a portable form before, and I notice it would get confused with the computers main firefox. I don’t know why.

Thanks for the suggestion.

How old is often questionable in your opinion?

It is browser, so it shouldn’t be old at all.

The Tor browser is fully portable.


Out of interest, why are you trying to use such an ancient web browser?

Can you explain your reason for wanting a portable browser?

If you just want your browser to be separate from the rest of your system you can use the flatpak version of almost any browser.


honestly I don’t think I’ve heard of a flatpak. I’m sorry, I’m new to linux.
I want portable browsing i don’t have to worry about if the rest of the pc gets messed up.

hi @s_p welcome to the purple universe :enos_flag: :enos: :purple_heart: :rocketa_purple: :penguin_face:

Pale Moon is portable and the latest release is from this year.
Stable release 31.1.0 7 June 2022; 24 days ago

It is not necessary to install Pale Moon to use it. Pale Moon for Linux is distributed as a xz-compressed tarball that can be extracted and run from any location on your system. If however you prefer to “install” it on your system, you can find instructions to do so here.



It is even possible to run the “regular” Firefox as portable if one so wishes.


that sounds neat!, and thanks for the welcome. :slight_smile:

1 Like

Just install flatpak. And then you can install the browsers you want. It will “just work”