Warframe keeps crashing after about a minute

Hey there!

I’ve recently switched from Manjaro to EndeavourOS. Previously I used versions of Ubuntu, and up until now the game had a fairly good performance. I had to adjust some in-game settings for a smoother experience but overall nothing game breaking.

Now that I installed EOS, however, I cannot seem to get the game to run at all. I haven’t changed any of my hardware. Is anyone currently playing the game? Have you had any issues?

The game does start, and runs completely fine for about a minute, and then suddenly crashes and opens up the hardware failure site (https://www.warframe.com/hardwarefail) in the browser. I cannot connect the crash to anything specific, it doesn’t seem to matter what I do in-game, after about a minute, it just closes, regardless of anything. There are no obvious signs before the crash, the game runs just fine, good fps, no lags, nothing out of the ordinary, really.

I tried looking at ProtonDB to see what others may have, I even tried matching similar builds, tried different Proton or Proton-GE versions, even downloaded older ones but the issue is still exactly the same. With every launch command or proton version, the game crashes.

On Manjaro, I could simply install the Steam version and run the game with stock Valve Proton, no other modifications were necessary.

I tried other games to see if it could truly be a hardware issue — I regularly play Dota 2 with no issues whatsoever, but from the Proton ones I tried Layers of Fear and Tomb Raider and they both ran smoothly with no problems whatsoever. The former ran with zero changes, with Tomb Raider I only changed the Proton version but otherwise that was perfect too. (And, again, even Warframe runs smoothly up until the minute mark.)

What could I be missing here? Raiding old forum posts about this specific crash yielded very old posts that were no use to me unfortunately.


NVIDIA GTX 1050 (525.85.05 driver — installed by nvidia-inst)
Intel i5 7400

DirectX 11 or DirectX 12?
Tried with proton-ge? Sorry, haven’t noticed at first.

Make sure to read Requirements section

Also i think you need to read some logs after crash to know more…

I read though the Requirements section and I seem to have everything I need. It uses Direct X 11 and the launcher doesn’t even allow me to change it.

As for logs, Warframe provides the EE.log, I made a gist. At the end it says “GPF”, could it be this? If so, does that help me? :thinking:

1 Like

Huh…That’s weird is it greyed out or something?


Yeah that’s definitely it…Not sure what to do with it yet.
Quick search show you’re not alone in that GPF problem on that game, looks like it’s not Linux only issue

Back in 2019 people advised to install those winetricks:

vcrun2015, msxml6, xact_64

(c) https://forums.warframe.com/topic/1138625-linuxwine-crash-during-loading-in-update-26-gpf-error-any-ideas/?do=findComment&comment=11239619

You can try this

I installed the components with protontricks, but that didn’t help me out unfortunately. I kept getting the same crash.

However, I did manage to fix the issue in a different way. For documentation purposes, I’m going to leave my solution here in case someone might need it in the future. I researched several different Linux-related crash cases and found out that usually the “device” errors are either caused by sound or “phantom joystick/controller” issues.

Here’s a list of everything I did, it’s possible that only one or some of these might be sufficient for you so I recommend trying them out one-by-one.

  • Add the following to the Steam library → Warframe options → Launch commands:
    gamemoderun WINEDLLOVERRIDES="xaudio2_7=n,b" DXVK_ASYNC=1 %command%
    (This requires **gamemode** to be installed.)
  • Install a dummy controller (as I do not own a physical one) following this method*
  • In the in-game Video settings I’ve set Vsync and everything that was set to “Auto” by default to “Off”. (It’s greatly possible that disabling Vsync alone is enough as that’s the recommendation in the majority of forum posts.)

With this, the crash no longer seems to happen and I managed to test the game for over an hour with no great issues. Sometimes certain visual effects might lag the game for a bit, so I’m going to keep adjusting the Video settings to see what sticks, but that’s probably a personal problem.

Either way, the crash itself is fixed, and if someone finds this in the future, I hope it helps them out.

*Edit: Here’s the content of the page in case it gets archived or deleted:

Dummy Controller method

Thanks to xarvh for making this possible

Makesure you have xboxdrv loaded as a service

to accomplish this, make sure you already have xboxdrv installed, sudo apt install xboxdrv if you do not

with that installed, you want to use the following command “curl -O https://gist.githubusercontent.com/xarvh/6abfbd176a48e21886813e98480e9dc5/raw/96642aeea1a1f59d9f59cff5b6ecbb20362fdfd3/xboxdrv.service” (Make sure you have curl installed, I think it comes preinstalled)

then type sudo mv xboxdrv.service /etc/systemd/system

after that, sudo systemctl enable xboxdrv

Then start it manually the first time, sudo systemctl start xboxdrv

Follow this guide and xboxdrv will be loaded as a service and Warframe will stop crashing because of not detecting a controller

gist contents (in case that doesn't work either)
Description=xboxdrv daemon

ExecStart=/usr/bin/xboxdrv --daemon --quiet --dbus disabled


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.