Wallpaper reverts to default

Hello, all. I’m new to EOS and Sway, and I’m enjoying both so far. However, whenever I use azote to change my wallpaper, it reverts back to default upon restart and/or login. I assume some kind of script causes this? I already disabled the welcome app. Thanks :slightly_smiling_face:

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

If you have eos-packagelist installed, you can enter
eos-packagelist i3-Window-Manager
and all the default installed packages are listed.

One package listed is nitrogen, which is the wallpaper app being used.
azote may not be setup correctly. Try nitrogen and see if that works.


sway should use swaybg, not nitrogen.

You need to change a line in ~/.config/sway/config.d/theme .
There is a line like this:

exec swaybg -i ~/.config/sway/sway.png

Change it to the path of the wallpaper you want to use.


easy way … rename or remove sway.png from z directory . find wallpaper you like , put in z directory + name it sway.png

no need play with config ( no all usr feel confident change config )

Your system ,Your rule


research alway a good thing ( if no sure go to source ) :wink: little search i do

" https://github.com/nwg-piotr/azote "


BTW he great dev… do wonder ful thing on sway/wayland ( respect )

1 Like

Thank you for the warm welcome :smiling_face:

This worked. Thank you! I even got multi-monitor wallpaper working with these options.

I actually did this at first, but I wanted to learn how to do it the proper way :wink:


why no say that then !!! :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.