VT1802 No Sound From Speaker and Headphone

Hello, greetings to all. I am confused where to start, this is what I will ask. First I’m not an expert in linux, I’ve always wanted to use linux but I’m having problems with audio. I’ve tried many linux including EOS, last night I tried from build :

  1. https://github.com/endeavouros-team/ISO/releases/download/1-EndeavourOS-ISO-releases-archive/endeavouros-2019.07.15-x86_64.iso

  2. https://github.com/endeavouros-team/ISO/releases/download/endeavouros-2019.07.15-x86_64.iso/endeavouros-2019.07.15-x86_64.iso

I’ve tried both releases on a live cd, but I’m not getting the audio to work.

  1. soundcar : VT1802
  2. Dualboot : Windows 10

I have read this thread :

but I don’t know what release he started from.
So what if the live CD sound doesn’t work, then when it’s installed into the disc the sound doesn’t work either.I’ve been on the verge of giving up VT1802 for years on linux

Have you checked


Edit: Check that the right sound card is being used and that the output is not muted or volume at minimum.

Edit2: https://discovery.endeavouros.com/audio/getting-information-while-having-sound-issues/2021/03/

Welcome to EndeavourOS
Have you had the sound issue on other linux distro’s you have tried? It seems the hardware isn’t setting up correctly on both booting on the live ISO or on the installed system. Sound issues can be quite time consuming to figure out on certain hardware.

I’ve checked in alsamixer, when I type the command that appears is pulseaudio, and I change it by pressing F6 and selecting VIA VT1802, I have increased all output volumes but but still no sound. this is the position I’m still trying with a live CD

I’m really frustrated, all linux nothing works

that’s right I haven’t found a solution for years

Same chipset, similar problems. Sometimes my sound works, then it stops working, pretty certain nothing I do fixes it… Then it randomly starts working.

Really, really frustrating.

Is this chipset rarely used by linux users, so developers are not interested in making it better?

No idea, I have a Clevo laptop, so I would assume fairly common.

What is the output of this command.

lspci -nn | grep -i audio
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)

Alright, I will study it and I will report back here, in advance sorry for late response to your comments, because my health condition is not good.

Sorry to hear that. I may be able to help but would need to see a lot of images and logs most likely. Maybe start with posting your hardware info. You can post the link from this command.

inxi -Faz | eos-sendlog

Also can you post the output of

inxi -Aa

Can you also check if sof-firmware is installed and sof-firmware alsa-ucm-conf. I think they both should be? It should show install date and reason.

pacman -Qi sof-firmware
pacman -Qi sof-firmware alsa-ucm-conf

I’m going to back track here. Do you actually have EOS installed? :thinking: If it isn’t installed it won’t be possible to diagnose the sound issue.

Sorry I forgot to mention one of the important points, yes I have installed it on the hard drive and not on the Live CD

Okay… i just wanted to check.

Edit: If you could start with those logs in the above posts.

[papaozi@papaozi-ih4el ~]$ inxi -Faz | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:05:00 --:--:--     0
curl: (28) SSL connection timeout

Sorry, my connection uses a proxy, I have set it up and it works on the terminal including pacman, but the proxy doesn’t work on all applications, what should I do now

What does this show?

inxi -Aa