VScode hangs on EndeavourOS

I tried installing vscode and its open source versions like codium, but each time I try running the binary it hangs and says “vscode is not responding”. I tried following this thread. But even after installing vscode through sudo pacman -S code and running code --disable-gpu it still hangs. I understand this post is probably lacking enough information to fully diagnose whats going wrong, so please let me know what I can do to get more info.

hello @aurreco
welcome to the purple universe :enos: :enos_flag: :penguin_face: :rocketa_purple: :purple_heart:

In order to find out what the error is, we need more information.
please run the following command and post the URL.

code --verbose | eos-sendlog

Hello @aurreco welcome to the purple side. :space_invader:

Don’t know if you want VSCode or Code which is the free open source un Microsofted version of VSCode.

If you want VSCode which is from Microsoft then use the AUR.

You can use yay to install it.

yay -S visual-studio-code-bin

If you want the free version then use.

yay -S code


yay -S vscodium

The last one is the same as code but it is used Git to build the latest.

Also, running and posting the results of the command given to you by @pycrk would help a lot too.

1 Like

Thank you! Here is the result after running that command: http://ix.io/4FEw

Difficult to say what triggers the error, it could be electron or code. the best thing to do with such errors is to create a bug report and inform the developers, e.g. on Github if the software is hosted there. I would be interested to know if you use plasma.

You could try the following command, maybe it will work.

code --no-sandbox
code --no-sandbox

unfortunately didn’t work. Not sure which software version to create a bug report with because this problem persists with regular vscode and codium. How can I troubleshoot it if it is a problem with electron? Any advice? Maybe I can uninstall and reinstall electron or check that the version is correct?

Did you upgrade before trying to install code?


I found your issue. It’s a security warning function logic check issue. Which is a reported bug in Electron github.

From your VSCode log.

[90496:0907/151851.509569:INFO:CONSOLE(2)] "%cElectron Security Warning (enableBlinkFeatures) font-weight: bold; This renderer process has additional "enableBlinkFeatures"
  enabled. This exposes users of this app to some security risk. If you do not
  need this feature, you should disable it.

This stops the app from rendering your workspaces (your UI).

This was a bug in Electron and was fixed according to this pull request.

Seems you have an old version.

Can you please post the out of yay -Qi code.


Today a new version of code was released, maybe it will fix the problem if everything else didn’t help.


1 Like

It might but I’m wondering how he managed to end up with an Electron version with that bug.

That will become apparent when OP shows his versions.
Normally pacman solves the dependencies and installs the correct version. I have now updated code and electron was also updated at the same time.

my versions:

code 1.82.0-1
electron25 25.6.0-1

I don’t use code I use visual-studio-code-bin from Microsoft. Haven’t given me any issues yet.

My code installation works without issues since i have installed it.

I think this was the bug! I upgraded my electron package and now code works! Thank you and @pycrk so much for the help!!

1 Like

I do as well. I think the MS version has its Electron embedded, so the Linux version of Electron is not a dependency.

Awesome, happy to help. Code comes without electron stange. Anyways your issue is solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.