VRAM overflow with 4070-ti

Hi!

After my full switch back from Windows to EOS is still considered „right“ and gave me many enjoyable moments, recently my system began to perform quite bad. Games, after a while, begin to stutter badly, Alan Wake II randomly crashes with RT enabled.
With the help of Mangohud I noticed that VRAM (12 gib) is gradually filling up, making games unplayable.
I am running Arch 6.6.7 and the Zen Kernel with same version number. No difference.

  • Wine 8.21
  • NVIDIA 545.29.06
  • DXVK 2.3
  • VKD3D 2.11.1
  • Latest Lutris and Steam
  • KDE X11

Already tried to downgrade one version of the NVIDIA drivers which led to almost having bricked my system :joy:.
I also tried to use KDE or Hyprland Wayland but also there VRAM runs full, above that, all games feel laggy in a certain way.

Any recommendations for a gamer loving Linux and especially this community but plagued by actually too many issues :see_no_evil:.

Not the recommendation you are hoping for, I bet:

Take a 15-minute break every 2 hours. During the break, actually exit the game, and the game client — not just pause it. Log out and log back in. Go stretch, get some coffee/tea/snack, a quickie/snuggle with your other half, etc.

This doesn’t fix the actual issue, but I find that I actually HAD the same problem, until I just stopped gaming for more than 4 or more hours without a break.

Also, it’s healthy, if that matters to you. :wink:

Hehehehe! I fully agree with what you wrote. I am a father and consequently have only an hour here and there for gaming. I do a lot of sports, have a quite exhausting job and yet enough quality time with my family. However, when there is time to dive into completely different worlds and forget about everything else, I don’t want to have that experience ruined by stutters, crashes,…

I know, I could just install Windows again and enjoy almost flawless gaming experience. But at the same time I really enjoy fiddling around with the system and still hope, that with the next nvidia release those issues will be gone ;).

Well, for sure, if you are gaming for under 2 hours and having any kind of stuttering, that is certainly a problem.

All in all, hope you find a fix or at least a workaround.

PS: If your system has Hybrid Graphics, make sure it’s actually switched on in the BIOS. Apart from reducing how long I’d game for before taking a break, I also recently went into my BIOS and switched it from Discrete Graphics to Hybrid Graphics, and it worked wonders across the board for gaming and general use.

I have disabled the CPU integrated GPU (Ryzen 5 7600) in the bios. So it should not have any effect or am I wrong?

That is actually the opposite of what I am recommending. Have a look at this as an example:

The excerpt above is from my post here: KDE5/QT5 And Lower Are Anti-Nvidia?

Though your setup may be different (as I have an onboard Intel GPU), you do have an Nvidia card. These cards cause issues with everything they feel like causing an issue with. Examples of these issues can be seen in the linked post.