VPN connection icon keeps disappearing from task manager

This seems to be a new problem. I’m running EOS Plasma and I connect to the internet via wireless. I can add a VPN connection for openVPN so I can connect back to my home servers when I travel. I create the connection by importing the .ovpn file.

Once the connection is created, I can click on the WiFi fan icon and the click connect on the VPN connection. It all works until I reboot. The connection icon is not one of the connections to pick in the task manager under the WiFi icon. And when I check system settings under connections the VPN that I imported is not there. I have to re-import it.

Any ideas?

Operating System: EndeavourOS
KDE Plasma Version: 5.27.2
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 6.2.2-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-2415M CPU @ 2.30GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 3000
Manufacturer: Apple Inc.
Product Name: MacBookPro8,1
System Version: 1.0

I tried testing this with X11 and now Wayland. The behavior is the same. I can import the ovpn file and the connection works. It just disappears on reboot. There doesn’t seem to be a way to save or make this permanent. I’ve tested this with Kubuntu 22.04 and the VPN connection Icon is permanent once imported. Seems to only be an issue with EOS.

I could not make the openvpn connection persistent through a reboot until I avoided using Plasma system settings. What worked was the following command from the console.

sudo nmcli connection import type openvpn file myopenvpn.ovpn


you might find use full

" nm-connection-editor "

great you fix your problem … nmcli alway good choice :+1:

1 Like

While I have a solution, I think the KDE > settings > system settings has a bug with persistent on the importing of a VPN. It didn’t happen with previous versions.

that KDE for you :rofl: :innocent: