Vmware player and vmtoolsd service issues


I’ve updated my EOS i3wm VM after 6 months. The biggest problem i found is that vmtoolsd needs to be restarted every time EOS boots up. Without systemctl restart vmtoolsd, the Vmware Player do not allows me to switch into dual monitor mode. After restarting vmtoolsd, everything works as expected.

I need some guidance on how to solve this issue properly. My first thought was to create shell script with restart command and add it to i3 config file or systemd, but Im not sure if this is right approach.

I have strange feeling that there should be more “clean” solution, becouse i don;t like to “hack” the system this way - its messy and after few months i may forgot wtf is this anyway.

I don’t have much knowledge about VMware, but just a sanity check - is the service enabled?

systemctl is-enabled vmtoolsd

You can enable it with this command :point_down:

sudo systemctl enable --now vmtoolsd

Welcome to the forum! :enos_flag:

After system boot when i type systemctl status vmtoolsd i see its up and running (image below).
i have also noticed that resolution is not as it should be and copy and paste features don’t work.


For what is worth, you could copy/paste terminal output into your posts and using the </> button to format it. This will make them searchable by search engines and more useful for others using one to look for a solution to similar issue.

Thanks and welcome to EnOS’ forum!

Not sure if this helps:

Additionally, to auto start vmware-tools on boot, create a new file /etc/systemd/system/vmwaretools.service:


Thanks for the answers.

I’m already dropping vmware for this particular machine.
This was my software developer VM, wery well configured so I wanted to rescue it, but it seems i dont have enough time and will to fight this.

I’m giving libvirt a try.
It’s not perfect choice for me, becouse my “bare metal” OS’s are Mint and Win10, so wmware VM’s was the best choice becouse of portability.

If it works after you restart the service there is a fix for that. I can probably find it with some searching.

If it doesn’t work after you restart the service, it might be a different issue.

If I saw correctly - you didn’t update for a long time? Before consigning to the dustbin - you might want to try updating incrementally, useing the Arch Archive capability. First back up to where it was before the first update, then set the date to perhaps 1 month closer to now and run an archive update.

Step back to the present 1 month at a time, and less may be messed up …

Just a passing thought!

Oh - more information on our wiki, or Arch’s - including an easy script for implementing.

You can just run a bash script on boot that restarts the daemon

edit : nvm, apparently I can’t read xD

Btw, what king of error does it throws at you?

Maybe the file permissions are whacky or the daemon starts too early (just a random thought)

It’s more then that. Problem is also with fresh EOS installations (latest build, online, i3wm). You have to manually restart vmtoolsd.service after each boot to make it works. From what i remember, vmware support for monitors and other stuff was always out of the box.

Maybe someone can check this with vmware player and fresh installation? Mine looks that:

Here is the solution for that:

Also make sure you have xf86-video-vmware installed.

If you want copy/paste support, make sure you have gtkmm3 installed in the guest as well.

I followed instructions and modified /etc/systemd/system/multi-user.target.wants/vmtoolsd.service.
Still the same.

Original file was:

Description=Open Virtual Machine Tools (VMware Tools)



I tried all combinations with this 3 entries:


Maybe the issue is that i don’t use full dekstop?

Perhaps. In that case, I would try solution #3 from this page:

1 Like

Yeah! :smiley:

So. You don’t need to modify service file. The only thing to do is load modules:


MODULES=(vsock vmw_vsock_vmci_transport vmw_balloon vmw_vmci vmwgfx)


sudo mkinitcpio -P

Thank You @dalto :slight_smile:

1 Like