VMware causes system to freeze

I have been using endevouros for almost a month now on my Thinkpad P52. Here’s the output of inxi -Fxxc0z. Everything runs fine except when I run a virtual machine using VMware. For some reason, after I shut down the virtual machine, I lose access to internet. Furthermore, applications start to freeze. Rebooting the laptop results in a very long waiting time where I start seeing messages such as A stop job is running for .... I usually just hold down the power button. I wonder if anyone can help me figure out what is causing this issue.

Here is the output of journalctl: https://0x0.st/HEaa.txt

1 Like

I don’t use VMware at all but I did find quite a few things researching your issue.
I found this post on the VMWare forums. And even though these users are on CentOS, Fedora and Ubuntu, this post on stackexchange has a plethora of possible solutions. Lots of mentions about disabling khugepaged de-fragmenting.

Hope this helps :slight_smile:

1 Like

Hiw did you install vmware?

1 Like

The log file shows that you are running vmware 17.0.2
The current version is 17.5.0. You should use the latest version.

How did you install vmware? Your log shows paths like : /mnt/hp_ssd/Downloads/vmware_install_modules_fix/vmware-host-modules-workstation-17.0.2 That is certainly not from the arch package.

Please install package “vmware-workstation 17.5.0-2” and try with that.

1 Like

Yes, definitely use the AUR package. Manual vmware installs will be difficult to maintain. However, before installing the AUR package, make sure you properly remove your current version including the kernel modules.

1 Like

I am using this version because I was having a keyboard latency with the latest version. It runs fine, except that the system freezes as I described in my original post.

1 Like

It is very tricky to not use the packaged vmware-workstation. Simply because as of package version 17.0.2 revision 2 the package contains bug fixes for kernel 6.4 and above.


If you want to stick to what you have installed now, you might want to try with kernel 6.1 (LTS).

1 Like

Thanks for the info. Could the problem that I’m experiencing be from this “incompatibility” between the kernel that I am currently on and the vmware version I am running?

I dont know. Just give it a try. The linux-lts kernel is just “one click” away.

This is exactly the same error/behaviour that I experience. But the symptons start already while using a virtual machine. Every command invoked with sudo freezes, same for ip a s and many more.

I use WorkstationPro 17.5.1, so it’s not because of the version. But I also use the original vmware bundle. I’ll switch to AUR version and report back.

Welcome! I use VMware all day every day.

Using the dkms modules from the AUR I have not seen any major issues i quite some time.

Reporting back with the AUR version of Workstation installed. Seems to work fine.

1 Like