Vivaldi Wayland - Hardware Accerelation and Vp9 decode

Hi. I’m currently using Vivaldi browser on Wayland on an AMD 6800XT GPU on EndeavourOS. I’m looking to get Hardware Accerelated video decode on Youtube, and I’m not able to get it to work. On X11, with the approrpiate settings, I’m able to get it working, but not on Wayland.

The flags I use to start Vivaldi are as follows:

/usr/bin/vivaldi-stable --enable-features=VaapiVideoDecoder,VaapiVideoEncoder,CanvasOopRasterization --ozone-platform-hint=auto --disable-features=UseChromeOSDirectVideoDecoder --ignore-gpu-blocklist --disable-gpu-driver-bug-workarounds --enable-gpu-rasterization --canvas-oop-rasterization --enable-zero-copy

Any help in getting this resolved is much appreciated.

(post deleted by author)

Have you installed vivaldi-ffmpeg-codecs ?

sudo pacman -S vivaldi-ffmpeg-codecs

You may also want to check the AMD driver is installed and working.

The open-source AMDGPU driver requires libva-mesa-driver:

yay -S libva-mesa-driver

The flags you might want to try:

--enable-features=UseOzonePlatform --ozone-platform=wayland

though ozone-platform= may have changed to:


If all else fails you might need to use:

yay -S chromium-wayland-vaapi

Edit : added info about chromium-wayland-vaapi and flags info.

1 Like

Hello @Melways . Thanks for the response. Unfortunately, none of those flags worked :frowning:

How did you test VP9 decode hardware acceleration on YouTube and knew it does not work on Wayland, but it works on X11?

Check vivaldi://gpu if it enables hardware acceleration.

It is turned on as per vivaldi://gpu

But when I play the Youtube video, here are my 2 observations:

  1. On the browser Task Manager, the video tab still used like 200-300+ CPU usage. On X11, this is like 20-30% max.
  2. I tried nvtop and do not see GPU decode on my 6800XT, it is at 0%. On X11, GPU decode usage is like ~35%.

I have the same setting as yours except disabling “Canvas out-of-process rasterization”

I checked nvtop on Wayland and it shows GPU usage ~8% for 4k VP9 decoding and ~15% for 8K on YouTube with AMD GPU.

Thank you. Turned off “Canvas out-of-process rasterization” and got the same results. It still uses CPU to decode. Not sure what else I could be missing here @Zesko

I checked nvtop on X11, it shows over ~30% GPU Usage for 4k more than Wayland.
But Wayland and X11 consume the similar CPU usage and my power meter shows that both draw the similar amount of watts. :man_shrugging:

Lucky you @Zesko . I’m still missing something here, a flag or something.

The startup flags I’m using right now are just these 2. Although no frame drops on 4K60 VP9, its clearly using the CPU. If I switch to 8K60, its a slideshow with framedrops all over.

/usr/bin/vivaldi-stable --enable-features=UseOzonePlatform --ozone-platform-hint=wayland

Can you test Firefox?
I noticed that Firefox uses less CPU usage than Vivaldi on Wayland when decoding 4K with VP9.


If it works for you, Vivaldi would be the problem.

Yes. Firefox works perfectly and I see GPU decode being used in nvtop. So, its an issue with Chromium based browsers I guess. I wish there was a way to get this working on Vivaldi on Wayland

I’m similar, but I have Vulkan enabled and Rasterization is just “hardware accelerated”.

Dont understand. Can you please elaborate?

when I type “vivaldi://gpu” compared to the image you posted when you typed it.