Virtualbox VMs stuck at start after recent update

I’ve run out of ideas, hopefully someone smarter than me can help figure out the issue…

So I’ve got a fairly clean, recently installed EndeavourOS on a random work laptop. Installed VBox, set up a W10 guest, all good. Then after a recent system update the VM wouldn’t start anymore, at all. “Starting virtual machine…” pops up, after a while a second notification (Starting virtual machine… (2/2)) with progress bar appears and gets stuck at 20% eternally. Can’t kill the processes either. VBox logs don’t show anything. I’ve found some hints on the internet that it might be due to mismatched VBox and Extensions version, but it’s all straight from the Arch repos.

Need to catch a train now, I’ll fill in details later.

Thanks for any idea!

Edit: Alright, some more details: I’m using virtualbox-host-modules-arch, but I’ve tried the DKMS version as well, same result. I’ve tried creating a new VM, same result. Tried to change virtually any setting (including deactivating networking and USB)… same result. Tried the LTS kernel, same-same. VMs simply don’t start anymore, and it gives me zero information as to what’s wrong. And it did work at some point not too far back!

So yeah, really not sure what else I could try.

Here the VBox log:

00:00:00.717357 VirtualBox VM 6.1.34 r150636 linux.amd64 (May 30 2022 06:37:05) release log
00:00:00.717359 Log opened 2022-06-02T15:50:51.448410000Z
00:00:00.717360 Build Type: release
00:00:00.717362 OS Product: Linux
00:00:00.717363 OS Release: 5.18.1-arch1-1
00:00:00.717363 OS Version: #1 SMP PREEMPT_DYNAMIC Mon, 30 May 2022 17:53:11 +0000
00:00:00.717384 DMI Product Name: HP EliteBook 840 G8 Notebook PC
00:00:00.717390 DMI Product Version: 
00:00:00.717394 Firmware type: UEFI
00:00:00.717706 Secure Boot: Disabled
00:00:00.717733 Host RAM: 31347MB (30.6GB) total, 30148MB (29.4GB) available
00:00:00.717735 Executable: /usr/lib/virtualbox/VirtualBoxVM
00:00:00.717735 Process ID: 62881
00:00:00.717735 Package type: LINUX_64BITS_GENERIC (OSE)
00:00:00.718902 Installed Extension Packs:
00:00:00.718912   Oracle VM VirtualBox Extension Pack (Version: 6.1.34 r150636; VRDE Module: VBoxVRDP)
00:00:00.719355 Console: Machine state changed to 'Starting'
00:00:00.719457 Qt version: 5.15.4
00:00:00.719464 X11 Window Manager code: 3
00:00:00.729213 SUP: seg #0: R   0x00000000 LB 0x0004d000
00:00:00.729232 SUP: seg #1: R X 0x0004d000 LB 0x00119000
00:00:00.729235 SUP: seg #2: R   0x00166000 LB 0x00060000
00:00:00.729237 SUP: seg #3: RW  0x001c6000 LB 0x000350a0
00:00:00.733365 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:00.733796 X Server details: vendor: The X.Org Foundation, release: 12101003, protocol version: 11.0, display string: :0
00:00:00.733807 Using XKB for keycode to scan code conversion
00:00:00.738057 GUI: UIDesktopWidgetWatchdog::sltHandleHostScreenAvailableGeometryCalculated: Screen 0 work area is actually resized to: 0x0 x 1920x1036
00:00:00.747493 GUI: Machine-window #0 activated
00:00:00.747537 GUI: Machine-view #0 focused, reason=3
00:00:02.697738 GUI: Machine-window #0 deactivated
00:00:02.697761 GUI: Releasing mouse on focus out
00:00:02.700233 GUI: Machine-view #0 unfocused, reason=3
00:03:17.288321 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={872da645-4a9b-1727-bee2-5585105b9eed} aComponent={ConsoleWrap} aText={Invalid machine state: Starting}, preserve=false aResultDetail=0

And here a screenshot of the mess:

Same here - nobody else with this problem? I think this should be fixed with priority by developers…

And it doesnt matter which OS you try to run, even new freshly imported Linux-OVAs dont work.

I can’t help with the problem - sorry. It happened to me once before some time ago, but unlike you, creating a new VM did not replicate the problem.

Right now, a Windows 10 VM is running OK in VirtualBox on EndeavourOS (kernel 5.18.1) for me.

No solution yet.
Reinstalling, new VDI import, creating new maschine, nothing works…

Works with Kernel 5.18.3

Afaik, the current Vbox setup only supports Linux kernels up to 5.17 officially, and for the VBox guest extensions that is still considered as “experimental” by Oracle.


1 Like