Virtualbox Stuck on 20% *SOLVED*

Hey everyone,

I know that there have been a lot of threads about this already but the ones that I found were regarding older versions of Virtualbox back when we were on the 5.x kernel. I followed this tutorial

I have tried both kernels. In the past I could get it to work on the LTS kernel - but that is not the case anymore. Does anybody know a fix for this?

I appreciate the help in advance.

EDIT: I found out the solution. I am on a newish 11th gen Intel processor and there has been some troubles when it comes to virtualization with these processors. I was able to add ibt=off within the kernel parameters and the VM’s started up right away.

You might want to double-check with this:

1 Like

a real good advice !
and note the kernel modules :slightly_smiling_face:

Sorry for the late reply - but yeah. I read over the archwiki as well and still had no luck. The EOS link is basically a condensed version of the archwiki. I’ve got the headers installed, I loaded the modules and I still have no luck getting virtualbox started for some reason.

hmm :confused:
I would try to start a completely new installation.
First only the Vbox without extensions and see if it will work…

sudo pacman -S virtualbox virtualbox-guest-iso
sudo gpasswd -a NAME vboxusers
sudo modprobe vboxdrv

before that of course

sudo pacman -S linux linux-headers
sudo pacman -S virtualbox-host-modules-arch