I haven’t touched anything related to VMs in ages, and haven’t used them in a couple weeks.

Now, after an upgrade (which I assume is the cause), all I get from any VM is

The VM session was aborted.
Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}

I am fond of maximally non-specific error messages…

I switched from dkms (I have linux, -lts and -zen) to modules-arch just in case, to no avail.

[2022-07-21T17:48:47+0200] [ALPM] installed virtualbox-host-modules-arch (6.1.36-1)
[2022-07-21T17:48:47+0200] [ALPM] removed virtualbox-host-dkms (6.1.36-1)
[2022-07-21T17:44:31+0200] [ALPM] reinstalled virtualbox (6.1.36-1)
[2022-07-21T15:22:28+0200] [ALPM] upgraded virtualbox (6.1.34-4 -> 6.1.36-1)
[2022-07-21T15:22:28+0200] [ALPM] upgraded virtualbox-host-dkms (6.1.34-4 -> 6.1.36-1)
[2022-07-21T15:22:28+0200] [ALPM] upgraded rubberband (2.0.2-1 -> 3.0.0-2)
[2022-07-21T15:22:28+0200] [ALPM] upgraded luajit (2.1.0.beta3.r422.g4c2441c1-1 -> 2.1.0.beta3.r431.g5677985d-1)

vboxdrv seems loaded

~  lsmod | grep vbox
vboxnetflt             32768  0
vboxnetadp             28672  0
vboxdrv               544768  2 vboxnetadp,vboxnetflt

I have no idea whether having two loaded is normal.

Does anyone have any idea what’s going on ?

I have no issue on vbox with the latest updates. I am not using zen but i don’t believe that would be an issue. Did you reboot after doing the updates? Mine is reporting the same info.

[ricklinux@rick-ms7c37 ~]$ lsmod | grep vbox
vboxnetflt             32768  0
vboxnetadp             28672  0
vboxdrv               544768  2 vboxnetadp,vboxnetflt
[ricklinux@rick-ms7c37 ~]$ 

After today’s VirtualBox update, I had to update the VirtualBox Extension Pack to version 6.1.36:


That was automatic for me. So i never tried v-box before the update so probably yes that is the OP’s issue. I just assume that they would already have the update as i did. But maybe they haven’t updated yet.

1 Like


Of course, I rebooted multiple times (once after each operation).
I have zen, but, like lts, it’s just a backup in case of breakage (that never happened), I don’t run it day to day.

I downloaded the new Extension Pack, and suddenly it works. Thanks @kwg !

Which raises the subsidiary question, how could that upgrade have been automatic ? I don’t see a corresponding package on

And I guess the answer to my own subsidiary question is that it’s on the AUR:

@ricklinux , is that what you use ?

If I remember correctly, the EnOS’ team used to add the virtualbox-ext-oracle to EnOS’ repo before, so it got automatically updated with the rest of the system. They dropped it some time ago.

1 Like

Yes that is the one i am using currently.

1 Like

True. We found out that having it in our repo may not be OK with the usage terms, so we dropped it.
However, it is easy to install or update using e.g. yay or paru.


I now have it installed from the AUR and (after a quick resolution for the conflict with the manually installed version) everything works nicely. Problem fully solved.

Thank you all for the kind help, and no thanks at all to VBox for using such an uninformative error message (NS_ERROR_FAILURE) for what should be an obvious versions mismatch.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.