VirtualBox Guests Lag Under Endeavour OS

Endeavour OS as a guest ran smoothly in VirtualBox running on Manjaro.

Switched Manjaro base with EOS, now every virtual machine struggles.

Manjaro guest’s cursor develops tremendous latency woes. EOS guests cannot get past this screen:


end of Xorg log. tty3


startx tty3


Beginning of log after startx. Moved to tty4 after tty3 became unresponsive.

And which videocard settings do you use the guest? there is Vboxvga and svga ?

VMSVGA is the default.

it doesnt like VMSVGA it likes vboxvga , in settings should be possible to change, currently dont use vbox so cant tell :slight_smile:

1 Like

It appears VirtualBox doesn’t like anybody. :laughing:


What indicates this inclination?

Did you try it without 3d enabled? I use 3d enabled when i use vboxvga and if i use vmsvga i don’t. But i too can confirm vbox doesn’t work well in my opinion. It’s slow, sluggish and can be unresponsive at times. I also saw the disclaimer! :blush:

@ringo, I understand now! Did some homework and VMSVGA is relatively new, very unstable.

Just tried, very broken and slow. Did get EOS guest to boot.

VBOXVGA is old but solid, supports 3D acceleration. Wished VMSVGA worked on my machine, great things to come I suppose.

3d acceleration is needed in more higher end desktop environment like Xfce not needed cinnamon also not if you use software rendering

I have the hardware, wanted to make use of it because why not? But ok, VBOXVGA it is! :slightly_smiling_face:

virtual hardware is different :slight_smile:

VboxSVGA is needed now… :wink:

1 Like