Virtualbox-guest-modules-arch doesn't exist anymore

Looks like virtualbox-guest-modules-arch is not longer available.

https://lists.archlinux.org/pipermail/arch-commits/2020-April/730584.html

`upgpkg: virtualbox-modules-arch 6.1.4-13

  • fixed and rebuilt for linux 5.6.0-arch1-1
  • vboxsf is upstreamed, so dropping virtualbox-guest-modules-arch`

I got this error when trying to build a new ISO:

I will try to build it without virtualbox-guest-modules-arch and see if it works in VBox or if it needs to be replaced by virtualbox-guest-modules-dkms.

@joekamprad and @manuel: are you aware of this building issue?

Edit: ISO was build without problem when I removed virtualbox-guest-modules-arch

I wonder if this removal will break chrooted_cleaner_script.sh in line #25

Any idea?

1 Like

Weird I have problem also to build Calamares, I don’t know if it’s related or not !!?

No but I noticed a problem with the testing repos about this vb package, pacman -Syu wanted to change it to testing/linux!
So something is really wrong there…

Thanks for informing us! We’ll have to change packages.

Nothing is wrong. Look at this content in https://lists.archlinux.org/pipermail/arch-commits/2020-April/730584.html : vboxsf is upstreamed, so dropping virtualbox-guest-modules-arch

Furthermore:

$ pacman -Ql linux | grep vboxsf                                        
linux /usr/lib/modules/5.6.2-arch1-2/kernel/fs/vboxsf/
linux /usr/lib/modules/5.6.2-arch1-2/kernel/fs/vboxsf/vboxsf.ko.xz
$ pacman -Qi linux | grep Version                                    
Version                  : 5.6.2.arch1-2

By the way, I installed an EndeavourOS + Budgie with an ISO without virtualbox-guest-modules-arch in it. Install was OK, reboot too.

1 Like

Sorry, the link does not work…

It will work better. I fixed it!

1 Like

Actually I tried the vboxsf a couple of days ago with kernel 5.6.2, and then e.g. folder sharing didn’t work.
So now I need to test that again. :wink:

Folder sharing doesn’t work anymore from latest vbox update…

Ouch!

What about these instructions?

https://wiki.archlinux.org/index.php/VirtualBox#Enable_shared_folders

1 Like

Strange. It works here. (guest : Win7 professional; VboxWindowsAdditions installed in guest)

yay -Qs virtualbox
local/libvirt 5.10.0-3
    API for controlling virtualization engines (openvz,kvm,qemu,virtualbox,xen,etc)
local/linux 5.6.2.arch1-2
    The Linux kernel and modules
local/virtualbox 6.1.4-5
    Powerful x86 virtualization for enterprise as well as home use
local/virtualbox-ext-oracle 6.1.4-1
    Oracle VM VirtualBox Extension Pack
local/virtualbox-ext-vnc 6.1.4-5
    VirtualBox VNC extension pack
local/virtualbox-guest-dkms 6.1.4-5
    VirtualBox Guest kernel modules sources
local/virtualbox-guest-iso 6.1.4-1
    The official VirtualBox Guest Additions ISO image
local/virtualbox-host-dkms 6.1.4-5
    VirtualBox Host kernel modules sources
local/virtualbox-sdk 6.1.4-5
    VirtualBox Software Developer Kit (SDK)

With AFP I don’t use it anymore for now it’s rolling… Calamares is more important :metal:

1 Like

The problem (at least here) was that the mountpoint folders in the guest had wrong permissions before mounting them.

The permissions they should have is:

$ ls -l /media | grep TEST
drwxrwx--- 1 root vboxsf 4096  8. 4. 13:15 sf_TEST

This way is works here.

So, the following commands should do the trick:

# change the mountpoint name (sf_TEST) for your system
sudo chgrp vboxsf /media/sf_TEST
sudo chmod g+rwx,o-rwx /media/sf_TEST
2 Likes