For those using virtual-box the extensions just updated to version 7.0.0-1 and virtual box is still version 6.1.40-1. When you try to run virtual-box you will get an error because the extension is installed but not active. If you switch USB settings in virtual-box to usb 1.0 it will work. Not sure when virtual-box 7 is out so either don’t update the extensions or you can change the usb setting. This is what i have found so far anyway unless someone else can tell me anything different.


You could also downgrade the extensions to match the virtualbox package in the repos.


I was worried that something like this might happen. I’ve set all my VB packages to Ignore until 7.x becomes more stable; way too many posts on their forums on v7.

Yes… I could do that and i might. I was just surprised the extensions are already updated and not virtual-box itself.

The extensions are an AUR package so they aren’t always kept in-sync with the rest of the virtualbox packages.

I just uninstalled it and then downloaded the ext package directly from oracle and added it manually in virtual-box. Not sure you can downgrade from the AUR since the old package won’t be there. So i guess you would have to use wget or some other way to install it? I did it this way for now and it won’t bug me to update it for now. When virtual box updates I could switch it back.

You can downgrade it if it is still in your cache. But yes, downloading them manually will also work. You can also remove the it altogether if you don’t need the functionality it adds


I downgraded it by downloading files from links

from the AUR. Note that you can download them with command

yay -Ga virtualbox-ext-oracle

Then changed the pkgver variable in PKGBUILD from 7.0.0 to 6.1.40 and installed it with commands:

sed -i PKGBUILD -e 's|^pkgver=7.0.0$|pkgver=6.1.40|'
updpkgsums      # forgot this line, sorry!
makepkg -cf
sudo pacman -U virtualbox-ext-oracle-6.1.40-1-any.pkg.tar.zst

I tried this but i get errors.

[ricklinux@kde-plasma ~]$ cd virtualbox-ext-oracle

[ricklinux@kde-plasma virtualbox-ext-oracle]$ sed -i PKGBUILD -e 's|^pkgver=7.0.0$|pkgver=6.1.40|'

[ricklinux@kde-plasma virtualbox-ext-oracle]$ makepkg -cf
==> Making package: virtualbox-ext-oracle 6.1.40-1 (Tue 18 Oct 2022 10:18:15 AM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading Oracle_VM_VirtualBox_Extension_Pack-6.1.40.vbox-extpack...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 10.7M  100 10.7M    0     0  49.8M      0 --:--:-- --:--:-- --:--:-- 49.8M
==> Validating source files with sha256sums...
    Oracle_VM_VirtualBox_Extension_Pack-6.1.40.vbox-extpack ... FAILED
==> ERROR: One or more files did not pass the validity check!

[ricklinux@kde-plasma virtualbox-ext-oracle]$ sudo pacman -U virtualbox-ext-oracle-6.1.40-1-any.pkg.tar.zst
[sudo] password for ricklinux: 
loading packages...
error: 'virtualbox-ext-oracle-6.1.40-1-any.pkg.tar.zst': could not find or read package
[ricklinux@kde-plasma virtualbox-ext-oracle]$ 

Edit: I guess I’m doing something wrong. :thinking:
Edit: Okay me dumb …i already removed the AUR version. :rofl:

I reinstalled the AUR package to try your method but i still get errors. It complains about the dash if i use
6.1.40-1 for package build and if i leave the -1 out it say’s it can’t find the package. So I’m not sure what I’m doing wrong.

Virtualbox 7.0.0-1 is in community-testing now:

1 Like

Trying it out now with the updated extensions.

1 Like

Normally i ran VMSVGA with 3D. Now you can’t check 3D or it doesn’t load the vm. So well see if this changes down the road. :thinking:

you need to update the shasums… updpkgsums before running makepkg …

I didn’t know how to do all that. Was just trying it to see but have since added the updated virtualbox from community testing anyway.

Sorry Rick!
Forgot the updpkgsums command right before the makepkg, just like Joe explained.
Adding it now, for future reference.

No problem i wouldn’t know how to do this anyway without you giving me the instructions. That is why i originally just installed the extension the manual way from inside virtualbox.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.