Virtualbox 6.1.12-4 fails

Hi!
Seems that the latest virtualbox on host is not working at all.
So I suggest people who use virtualbox put this line into their /etc/pacman.conf:

  IgnorePkg = virtualbox virtualbox-host-dkms

and possibly downgrade those packages to version 6.1.12-3.

Seems also that virtualbox guest is not affected, but I didn’t test this throughly.

6 Likes

I’ve just updated to these versions too. I haven’t rebooted yet though. :wink:

Here reboot didn’t make a difference. Downgrading helped.

1 Like

It’s preparation for Kernel 5.8, which should follow very soon.
So don’t forget to unignore when 5.8 hits the repos :wink:

3 Likes

Yup, looks like the patch for 5.8 breaks the driver for other kernels. :grin:

(Or, at least for me, linux-ck-zen=5.7.15)

5 Likes

It’s an interesting patch - much larger than the one I used for my 5.8 and which also worked.
Probably more changes under the hood, and maybe with this one we do not need to patch the kernel.

1 Like

Thanks for alerting us, I was just about hitting enter on yay :slight_smile:
I heavily depend on Virtualbox.

2 Likes

Interestingly enough, here, it does work with 5.7.12 and VBox 6.1.12-4 ???

Although I compiled VBox myself, it’s almost identical to Arch’s, only inclusion is a patch for i3 and disabled WebService.

1 Like

Mine was broken as well. I had to downgrade to 6.1.10 version for it to work.

Shoot. I read this right after hitting y to update :stuck_out_tongue_winking_eye: Thanks for the heads up, I’ll downgrade accordingly.

1 Like

Not to blame on Virtual box, but try qemu instead with easy managing:

3 Likes

You also need the latest development build for the extensions and guest ISO.
I got nasty coredumps and bugs with the 6.1.2 release version:

kernel: VMSVGA FIFO[2383]: segfault at f8 ip 00007dda68f30279 sp 00007dd9959fec70 error 4 in libX11.so.6.3.0[7dda68f2e000+8a000]

1 Like

Okay, gets worse… complete crash and reboot.
No entry in the journal.
However I suspect it’s the same issue I had a few days ago:

kernel: softirq: huh, entered softirq 7 SCHED 00000000e35fd30b with preempt_count 00000101, exited with 00110101?
kernel: BUG: scheduling while atomic: VMSVGA FIFO/277560/0x00110001
kernel: BUG: scheduling while atomic: EMT-5/277551/0x00000002
kernel: Preemption disabled at:
kernel: [<0000000000000000>] 0x0
kernel: BUG: scheduling while atomic: swapper/3/0/0x00110001
kernel: rcu: INFO: rcu_preempt detected stalls on CPUs/tasks:
Aug 08 21:33:53 db700 kernel: rcu:         Tasks blocked on level-1 rcu_node (CPUs 0-15): P277551
[...]

I’ve got virtualbox 6.1.12-4 working now …

I’ve installed the following updates today:
virtualbox 6.1.12-4
virtualbox-ext-oracle 6.1.13.139853-1
virtualbox-host-modules-arch 6.1.12-8

virtualbox was broken when I first got the 6.1.12-4 update, then still broken when I got the host-modules-arch 6.1.12-8 install … but now that I have also updated to the ext-oracle 6.1.13.139853-1 package from AUR everything seems to be working again.

PS - no custom kernel builds or anything on my side. just running linux 5.7.12.arch1-1 from the repo

5 Likes

@joekamprad

I also have virtual box up and running now with the latest update that just came through.

Edit: Not so sure it’s working though? Trying an install of Deepin and i think it’s froze up? :unamused:

1 Like

I have tried a couple different install on v-box and it’s just freezing at 28%. So it’s still not working for me. :pouting_cat:

v-box is chugging through some guest OS updates for me … so far so good …

virtualbox-host-modules-arch 6.1.12-8 fixed it …

I got the problem too. Temporarily switch to Neon to continue my work while waiting for the fix.

Downgrading for now also works. Possibly less drastic than switching OS. :wink:

2 Likes