Virt-manager pool-pfad

mit virtualisierungen habe ich mich bisher nicht wirklich befasst, da ich aber mehrfach von der möglichkeit gelesen habe, dadurch fwupdates via usb durchführen zu können die leider wndws zwingend voraussetzen, klingt das gleich wieder sehr spannend.

also habe ich mir (yay -S virt-manager qemu ebtables) installiert & dienste gestartet. eine wndws testinstallation in einer vm war dann überraschenderweise auch wirklich einfach gemacht. den image pool habe ich aber aus platzgründen von /var/lib/libvirt/images auf eine externe festplatte verlegt und den alten pool entfernt.

wenn ich jetzt aber eine neue vm erstellen möchte und die im pfad enthaltene iso auswähle, erscheint immer ein hinweis: keine suchberechtigung für den pfad. ein klick auf korrigieren führt zu einem fehlerhinweis, daß das starten der vm wohl scheitern wird.

dabei fragt virt-manager zum start nach dem admin passwort und das neue zielverzeichnis erfordert nicht mal mehr rootrechte wie im alten pool zuvor?

auf https://wiki.archlinux.org/index.php/Libvirt habe ich bestimmt etwas überlesen, nur was?

kurzer nachtrag:

so wie ich es verstanden habe, braucht es keine neue regel oder gruppenzugehörigkeit für die verbindung zum rw daemon, sofern man teil der wheel gruppe ist.

trotzdem habe ich die hinweise unter using polkit einmal getestet. der effekt ist dergleiche, nur das virt-manager dann passwortlos startet.

1 Like

danke joe, aber das hilft in diesem fall leider nicht weiter.

installiert habe ich ja bereits und alles funktioniert auch (s.o.), solange es nur beim default-pool bleibt.

das terminal gibt zum zeitpunkt des fehlers leider gar nichts aus.

was ich noch versucht habe: dem zielordner (usb-laufwerk) die gruppenrechte von wheel bzw. libvirt zu geben. ändert auch nichts.

/var/lib/libvirt/images is der default Pfad für die Festplattenabbilder im Virtmanager, ein POOL muss immer erst deaktiviert und dann gelöscht werden, den Pfad zu löschen reicht nicht aus, sonst wird ein Fehler angezeigt da Virtmanager diesen nicht finden kann er aber noch eingetragen ist…

1 Like

das ist richtig, auch wenn es nicht das problem war :slight_smile:

ich glaube, man konnte ihn gar nicht löschen, ohne ihn vorher auch gestoppt zu haben.

ich habe das hier gefunden: https://sysadminde.com/questions/840519/how-to-change-the-default-storage-pool-from-libvirt

es gibt so viele tipps dazu, die auch teilweise voneinander abweichen.

ich zeige mal, was ich mit default einstellungen im terminal versucht habe:

zuvor:

$ sudo gpasswd -a <user> libvirt

nun kann man passwortlos virt-manager starten

nach neustart:

$ sudo systemctl start libvirtd.service
$ sudo systemctl start virtlogd.service

dann

$ virsh pool-list
 Name   Status   Automatischer Start
--------------------------------------

sollte da jetzt nicht: default active yes erscheinen?

$ virsh pool-destroy default
Fehler: Konnte Pool 'default' nicht ermitteln
Fehler: Storage pool not found: no storage pool with matching name 'default'

in der gui kann ich zumindest pools löschen und anlegen.

╭─joekamprad@empowered64 ~ 
╰─$ virsh pool-list
 Name   Status   Automatischer Start
--------------------------------------

╭─joekamprad@empowered64 ~ 
╰─$ sudo virsh pool-list
[sudo] Passwort für joekamprad: 
 Name                  Status   Automatischer Start
-----------------------------------------------------
 default               Aktiv    ja
 develisos             Aktiv    ja
 Downloads             Aktiv    ja
 Festplattenabbilder   Aktiv    ja

danke für deinen langen atem :slight_smile:

ich hatte es auch mit sudo probiert, frag mich bitte nicht, warum es jetzt zumindest bis zu diesem punkt geht:

$ sudo virsh pool-define-as --name default --type dir --target/run/media/<user>/EXTSSD/kvm
Fehler: Befehl 'pool-define-as' unterstützt die Option --target/run/media/<user>/EXTSSD/kvm nicht

in der gui habe ich diesen pool ohne probleme angelegt bekommen - beim erstellen einer vm kommt es dann zu dem hinweis.

ich habe aus neugier mal einen usb stick grafisch als pool definiert - gleicher fehler beim erstellen der vm. als nächstes eine feste tmpfs unter /media/test. der fehler tritt dort nicht auf (ebenso wie unter /var/lib/libvirt/images).

es scheint etwas mit dem pfad /run/media/… zu tun zu haben bzw. mit laufwerken, die nicht fest eingetragen sind?

aus platzgründen und da ich die vm nur sehr selten benutzen werde, wollte ich das ganze flexibel auslagern und nur bei bedarf manuell starten.

1 Like