Vim terminal maxed can't restore to any size apart from max

I use vim and felt it is somewhat not normal … i found it is hard to resize it as wish as compare to just konsole alone.
I can any how "meta left / right/up/down, but todo that in vim is … not normal.
I will do a bit more on vim then describe my encountered issue.
Pls help me to unmax my vim and bring the vim konsole menu bar back (i was trying things and clicked remove menu bar).
Now my vim is maxed my monitor and no menu bar… refuse to be resize and budge.

This is maxed vim with menu bar

This is maxed vim , refuse to budge without menu bar.

CTRL+m toggles the menu bar in Plasma.

I’m not sure what you’re asking about the resizing, though…

ctrl - m in vim is no use… it just move cursor a line below… it became vim command.

1 Like

Sorry, then. I haven’t used vim in many, many years.

For konsole it’s Ctrl+Shift+m . Ctrl+m for every other KDE applications


Ctrl+shift+m toggle menu of terminal .
My problem was way more than that.
Vim terminal was Maxed to full screen. Even the top window frame is not in sight.
It was like borderless terminal.
I couldn’t get it “not maximized”. Hence resolve to close it and restart.

You accidentally hit the F11 key it maximized the terminal like that. :man_shrugging:


Well there is an option Exit full screen mode in View settings . It also shows the shortcut F11 right to it .

You should really start to check out the options in menus . At least Settings > Configure Keyboard Shortcuts

It’s only a request
1 Like

Thank you! Now i learn something, which will never happen again.


Sure, i will check the shortcut. Thanks
That time i can’t get my vim terminal to restore to normal is because, it was F11 and ctrl + shift + m , both together… hence i can’t get it out…