Videos won't play anymore, and neither does sound

I think it happened after an update, the most significant thing I can think of was something audio related being replaced, but I usually update before going to sleep and I was pretty tired so I don’t remember clearly.

On firefox based browsers (I use librewolf, but I tried firefox as well) videos just won’t play. On a chrome based browser (vivaldi) youtube videos didn’t play, but other videos played, if very poorly.

If I try to play videos with mpv they won’t play at all, vlc plays video, but there’s no sound.

Sound seems to be lacking everywhere though.

Neofetch output for info: https://i.imgur.com/4pivksY.png

EDIT: feeding “wireplumber” to the terminal made videos and sound on firefox work, but outside of that change everything seems to be the same.

EDIT2: pipewire tried to replace pulse, not all packages were removed during the process, I manually removed what was left and now it’s all ok.

2 Likes

I’am glad that i didn’t update my system

They won’t go away!

:ghost:

Not everybody has that issue, I didn’t do any manual intervention at all and after the update, video and audio worked as before on the system, Firefox and Vivaldi.

4 Likes

I’m definitely having this issue. I’m glad I’m not the only one- even happier its solved.

How did you find out which pulse files were left behind? Can you provide just a bit more instruction please?

Thank you!

EDIT: Went scanning the forums after finding this thread & found out that installing wireplumber & a reboot will do the trick. Ran an upgrade and a paru -Syu fixed then everything worked.

EDIT 2: Another update came, which I absent-mindedly ran wiped it out again.

Thanks everyone! Good luck!

In my case, this update came together with the kernel updates, so that reboot is clearly the “intervention” that explains why I didn’t have this issue. :wink:

Lesson when an update seems to error your system, try a reboot first… :wink: :grinning:

I have the same issue … feeding “wireplumber” is not solving the issue … what to remove manually to solve this

If you think the switching to wireplumber is causing the issue you are having, pipewire-media-session is back in the repos. You could try installing that. It will ask you to remove wireplumber.

… thanks … this solve my problem …

1 Like

Good to hear that!
Welcome to EnOS’ community!
:enos_flag: