Video Problems on XPS w/ Iris Plus graphics

I posted about this in the EndeavourOS telegram, for those of you in there, you might’ve seen it.

Setup

I recently installed EOS on my new Dell XPS 2-in-1 (7390, 2019 model, i7 with “iris plus” graphics). This is the first time I’ve installed linux on this computer, but the 3rd or 4th time I’ve installed EOS on a computer, and the hundredth time I’ve installed some distro on some machine. (12 happy years on Linux now!)

I’m using i3-gaps, and I’ve installed no special graphics drivers or anything; just whatever’s installed by default. I’ve updated everything (pacman -Syu). The issue appears to be related to graphics, and Chromium, vlc, and mpv are incapacitated by it.

Problem

Whenever I launch a video using mpv, the video appears to play maybe the first 2 frames, over and over. If I swap from tiled to floating window (effectively resizing the video), it will continue to play just a frame or two, but now, it will be at the position in the video where it would have been if the video had been playing correctly. (This is why I think the issue is purely graphical, rather than something wrong with how the file is playing.) It happens with every video file type I’ve tried: .mp4, mpg, .avi, .webm, .flv, even .gif.

I’m not sure if I’ve explained this well, so I made a little video of it. In the video, I’m playing a clip and switching between tiling and floating (in i3). As you can see, the video doesn’t visibly progress, but somehow is still progressing. The clip works in MPlayer, and it’s a pretty standard clip, so I think it can be considered normal and not the problem.

VLC does the same thing as mpv. MPlayer plays videos normally.

Another problem, which I think is related, is in Chromium. When I open the program, it appears normal, but if I try to interact with it in any way, the appearance doesn’t change at all. Opening a new tab doesn’t open a new tab, when I type in the address bar, no text appears, etc, If I open it from a terminal, I can see the following error:

[4404:4404:0202/121008.015377:ERROR:sandbox_linux.cc(372)] InitializeSandbox() called with multiple thr
[4404:4404:0202/121008.051862:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[4379:4379:0202/121008.244878:ERROR:CONSOLE(1)] "Refused to execute inline event handler because it violates the following Content Security Policy directive: "script-src 'strict-dynamic'

…then a bunch of sha-256 stuff.

That GL error stuff is why I think it’s graphical, and related to the video problem.

Firefox works fine.

Anyone have any ideas where to start?

TIA.

@c2lknt

The problem is that it is a very special machine, drivers and so on, but from what I could read of its model, it can be used in a decent way.
I found those links, maybe you already read them, I hope they are useful.


https://wiki.archlinux.org/index.php/Dell_XPS_13_(9360)#Firmware_Updates

https://wiki.ubuntu.com/Dell/XPS/XPS-13-7390-2-in-1

$ yay intel iris
1 aur/intel-opencl 5.0.r63503-2 (+27 0.25%)
Legacy OpenCL(TM) 2.0 Driver for Intel(R) HD, Iris(TM), and Iris(TM) Pro Graphics for Linux (pre-Broadwell)

Thank you! This fixed Chromium! Which is great. It didn’t help the video issue, though. Halfway there!

To permanently disable hardware acceleration, create a file:

/etc/X11/xorg.conf.d/disable-gpu.conf

with the the content:

Section "Extensions"
    Option "GLX" "Disable"
EndSection

intel-opencl didn’t help. It hasn’t been updated in over a year, and Iris Plus graphics are pretty new (I think?), so I wasn’t too surprised about that.

I’ve seen some people talking about how the new version of mesa (20.0) works well with Iris Plus, but I’ve also seen that maybe those changes were implemented in 19.3, which is the one I have. Is there a way to test 20.0, or is that not recommended?

I think this may be helpful.

https://www.phoronix.com/scan.php?page=news_item&px=Mesa-20.0-Iris-Gallium3D-Target

https://www.phoronix.com/scan.php?page=news_item&px=Mesa-20.0-Default-Build-Iris

I tried

MESA_LOADER_DRIVER_OVERRIDE=iris

(Just entered it in the terminal and pressed enter - do I need to add it to a config file somewhere?)

It didn’t give an error, but the issue wasn’t resolved. FWIW, glxinfo wasn’t installed, so I installed it (via mesa-demos) and now that I have installed it, it just gives the following error:

Error: couldn't find RGB GLX visual or fbconfig

(Any thoughts on that?)

Then I installed mesa-git (from AUR), which is mesa version 20.0, and that didn’t resolve it either.

Any thoughts/reactions/ideas?

Try reinstalling libgl.

sudo pacman -S libgl

This is all the info i can give you. It’s a lot of information so i would read from the top of the page. Iris info is on it.

https://wiki.archlinux.org/index.php/Intel_graphics

Edit: Additional info

@c2lknt
Did you try this kernel parameter for screen flickering?

https://wiki.archlinux.org/index.php/Intel_graphics#Screen_flickering

I’ve been reading over the last few days, and no luck…

The intel page on the arch wiki didn’t have much to say about videos. I reinstalled libgl and everything else xorg-related that I could think of. No success…

I’m stuck on the idea that the glxinfo failure is related, but I’m not sure what to do with that suspicion.

Do you have installed?
mesa-demos

Pacman -Qi mesa-demos

@other

What reaction does it produce on your desktop, when you type this command in your console or terminal:

$ glxgears

?

1 Like

Are you currently using the Intel driver or the modesetting if I’m asking this right? I really think you only have a couple of options. Myself I think I would stick with the Intel with these newer kernels and try working with that. Maybe put a bug in Dells ear and maybe they will get at Intel. They have more clout since they buy the components. I don’t know what else to tell you but keep looking for a solution. What works better the Intel driver or other? Or both about the same just different issues?

1 Like

@c2lknt
Have you looked at this on Arch forum? I can tell you that V1del moderator knows what they are talking about.

https://bbs.archlinux.org/viewtopic.php?id=250024

glxgears:
Error: couldn't get an RGB, Double-buffered visual

Just to close this out - I’ve been unable to find a solution. Just gonna wait and hope the issue gets fixed in a future update.