Video playback very laggy

Yesterday I’ve got some MP4 videos taken using a drone and the playback is very laggy on Celluloid (default Cinnamon DE app for playback videos), even I’ve tried on MPV with same results. Also CPU usage is pretty high.

Output from inxi -Fxmz:

  Kernel: 5.19.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: Cinnamon v: 5.4.12 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: TOSHIBA product: Satellite L55t-B v: PSKTLU-001NC1
    serial: <superuser required>
  Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1
    v: Type2 - Board Version serial: <superuser required> UEFI: INSYDE v: 2.00
    date: 12/02/2014
  ID-1: BAT1 charge: 29.5 Wh (100.0%) condition: 29.5/44.1 Wh (66.8%)
    volts: 16.9 min: 14.8 model: Panasonic PA5186U-1BRS status: full
  RAM: total: 7.68 GiB used: 4.49 GiB (58.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: dual core model: Intel Core i5-5200U bits: 64 type: MT MCP
    arch: Broadwell rev: 4 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 1805 high: 2196 min/max: 500/2700 cores: 1: 2196 2: 931
    3: 2196 4: 1899 bogomips: 17567
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel HD Graphics 5500 vendor: Toshiba driver: i915 v: kernel
    arch: Gen-8 bus-ID: 00:02.0
  Device-2: IMC Networks TOSHIBA Web Camera - HD type: USB driver: uvcvideo
    bus-ID: 2-6:5
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: intel unloaded: modesetting gpu: i915 resolution: 1: 1920x1080~60Hz
    2: N/A
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa
    22.1.7 direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Toshiba driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Toshiba
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.19.8-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
  Device-1: Broadcom BCM43142 802.11b/g/n vendor: XAVi driver: wl v: kernel
    bus-ID: 07:00.0
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Toshiba
    driver: r8169 v: kernel port: 3000 bus-ID: 08:00.0
  IF: enp8s0 state: down mac: <filter>
  Local Storage: total: 1.02 TiB used: 223.38 GiB (21.4%)
  ID-1: /dev/sda vendor: A-Data model: SU650 size: 111.79 GiB
  ID-2: /dev/sdb vendor: Toshiba model: HDWL110 size: 931.51 GiB
  ID-1: / size: 108.98 GiB used: 26.17 GiB (24.0%) fs: ext4 dev: /dev/sda1
  ID-2: /boot/efi size: 511 MiB used: 448 KiB (0.1%) fs: vfat
    dev: /dev/sda2
  ID-3: /home size: 175.7 GiB used: 72.04 GiB (41.0%) fs: xfs
    dev: /dev/sdb3
  ID-1: swap-1 type: partition size: 11.72 GiB used: 1.3 MiB (0.0%)
    dev: /dev/sdb1
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 251 Uptime: 9h 10m Init: systemd Compilers: gcc: 12.2.0
  Packages: 1202 Shell: Bash v: 5.1.16 inxi: 3.3.21

Video information:

Complete name                            : DJI_0481.MP4
Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom (isom/iso2/avc1/mp41)
File size                                : 446 MiB
Duration                                 : 36 s 137 ms
Overall bit rate                         : 104 Mb/s
Writing application                      : Lavf56.15.102

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L5.1
Format settings                          : CABAC / 1 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 1 frame
Format settings, GOP                     : M=1, N=44
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 36 s 137 ms
Bit rate                                 : 104 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 29.970 (30000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.417
Stream size                              : 446 MiB (100%)
Codec configuration box                  : avcC

Is it a problem with codecs or should I start thinking about buy a new computer?

Thanks in advance.

I’d be curious to see the output from vainfo.

1 Like

Thanks for your suggestion, I’ve tried it, but got this message:

vaInitialize failed with error code -1 (unknown libva error),exit

I guess I need to install something, but I’ll deep into it tomorrow, right now it’s time to go home.

Make sure you have libva and libva-intel-driver installed.


Thanks. I’ve searched and installed libva but I missed libva-intel-driver, now the output is:

vainfo: VA-API version: 1.15 (libva 2.15.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Broadwell - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      :	VAEntrypointVLD
      VAProfileH264MultiviewHigh      :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileH264StereoHigh         :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointVLD

So that should allow for hardware video decoding. Any improvement on your original problem?

1 Like

Take a look at Hardware video acceleration - ArchWiki (

Also, it appears you may also want to install intel-media-driver package.

1 Like

For a 4K video with a big bitrate like this you need a more powerful GPU for a smooth playback.
Hardware decoding might help a bit :

celluloid --mpv-hwdec=vaapi DJI_0481.MP4
1 Like

Just a little bit, now lag is less noticeable, but is still there.

No difference at all with intel-media-driver.

I still have lag and CPU usage at 100%

No luck, for sure I need more power, maybe I can try with an eGPU.

Anyway, thanks @jruschme and @vazicebon for your replies and effort on try to help, I really appreciate it.