Video not working

So i’ve been trying to watch videos on my browser but it seems none of them work, i tried watch netflix youtube disney plus but none worked. Please help me.

Hello @falkon2

1 Like

Which browser are you using also? Some browsers need to have DRM playback enabled in the settings in order to be able to play videos from those sites

1 Like

System:
Kernel: 5.15.40-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 wm: xfwm dm: LightDM
Distro: EndeavourOS base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Laptop 15s-eq0xxx v: N/A
serial: Chassis: type: 10 serial:
Mobo: HP model: 86FD v: 99.42 serial:
UEFI-[Legacy]: AMI v: F.54 date: 11/26/2021
Battery:
ID-1: BAT0 charge: 27.2 Wh (78.2%) condition: 34.8/34.8 Wh (100.0%)
volts: 13.0 min: 11.3 model: Hewlett-Packard Primary serial: N/A
status: charging
CPU:
Info: quad core model: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx
bits: 64 type: MT MCP arch: Zen/Zen+ note: check rev: 1 cache: L1: 384 KiB
L2: 2 MiB L3: 4 MiB
Speed (MHz): avg: 1236 high: 1309 min/max: 1400/2300 boost: enabled
cores: 1: 1208 2: 1231 3: 1224 4: 1309 5: 1223 6: 1224 7: 1226 8: 1244
bogomips: 36731
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: Hewlett-Packard driver: amdgpu v: kernel pcie: speed: 8 GT/s
lanes: 16 ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 04:00.0
chip-ID: 1002:15d8
Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
bus-ID: 3-1.2:3 chip-ID: 0408:5365
Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver:
X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96
Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x61ed res: 1920x1080
dpi: 142 diag: 395mm (15.5")
OpenGL: renderer: AMD Radeon Vega 10 Graphics (raven LLVM 13.0.1 DRM 3.42
5.15.40-1-lts)
v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
bus-ID: 04:00.1 chip-ID: 1002:15de
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
driver: snd_pci_acp3x v: kernel pcie: speed: 8 GT/s lanes: 16
bus-ID: 04:00.5 chip-ID: 1022:15e2
Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
bus-ID: 04:00.6 chip-ID: 1022:15e3
Sound Server-1: ALSA v: k5.15.40-1-lts running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Realtek RTL8723DE 802.11b/g/n PCIe Adapter
vendor: Hewlett-Packard driver: rtw_8723de v: N/A pcie: speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 02:00.0 chip-ID: 10ec:d723
IF: wlan0 state: up mac:
Bluetooth:
Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
bus-ID: 1-4:2 chip-ID: 0bda:b009
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address:
Drives:
Local Storage: total: 476.94 GiB used: 135.64 GiB (28.4%)
ID-1: /dev/nvme0n1 vendor: Western Digital
model: PC SN520 SDAPNUW-512G-1006 size: 476.94 GiB speed: 15.8 Gb/s
lanes: 2 serial: temp: 43.9 C
Partition:
ID-1: / size: 173.42 GiB used: 135.64 GiB (78.2%) fs: ext4
dev: /dev/nvme0n1p5
Swap:
Alert: No swap data was found.
Sensors:
System Temperatures: cpu: 44.0 C mobo: N/A gpu: amdgpu temp: 59.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 278 Uptime: 39m Memory: 9.7 GiB used: 3.29 GiB (33.9%)
Init: systemd v: 250 Compilers: gcc: 12.1.0 Packages: 1163 pacman: 1157
flatpak: 6 Shell: Zsh v: 5.9 running-in: xfce4-terminal inxi: 3.3.15

firefox, chrome and chromium

In Firefox go to settings and scroll down the page and see if this is checked on

1 Like

it is on yeeaah

Another thing I thought of do videos saved on your computer play? If they don’t then it’s probably a codec or driver issue.

1 Like

Saved videos do run my on computer

Have you tried clearing the cache and cookies? Although since you said its happening on all your browsers may not work. Also do you have any extensions enabled?

It’s been a while since the wirelumber “incident” but since that caused videos not playing on browsers so perhaps it’s worth a check.

@falkon2, could you post the output of:

pacman -Ss pipewire | grep inst

?

Edit:

You would need to have either Pulseaudio or Pipewire running. Have a look at the relevant articles here:

Firefox > Enable DRM
Chrome > Nothing needed
Chromium > needs Widevine decryption plugin
Edge > Same as Chrome

╭─ ~   :heavy_check_mark: ─╮
╰─ pacman -Ss pipewire | grep inst ─╯
extra/gst-plugin-pipewire 1:0.3.51-1 [installed]
extra/pipewire 1:0.3.51-1 [installed]
extra/pipewire-alsa 1:0.3.51-1 [installed]
extra/pipewire-jack 1:0.3.51-1 [installed]
extra/wireplumber 0.4.10-3 [installed]

I am not near my EnOS/Arch machine right now to check things but if you want to run on pipewire only you could try installing `pipewire-pulse’. First make sure your system is up-to date:

sudo pacman -Syu

then

sudo pacman -S pipewire-pulse

This latter package should replace a copule of pulseaudio packaes (pulseaudio and pulseaudio-bluetooth if I remember correctly). Say yes to removal. Reboot and check if you have sound.

If still you have issues, replace wireplumber with pipewire-media-session:

sudo pacman -S pipewire-media-session

Reboot.

In case you want to stick with pulseausio, please read: