Video not working in my setup

When I try to play a YouTube video, I get the message “If playback doesn’t begin shortly, try restarting you device”.
No other video players or audio players work, they all just give me a loading screen like YouTube. How can I get around this error without rebooting, I have some processes on my pc that I’d like to refrain from stopping every time something goes wrong.

This same problem has been documented on windows as well as debian distros, but I’ve yet to find a solution to it for arch forks.

We would need more information such as hardware and what browser are you using for instance.

inxi -Faz --no-host | eos-sendlog

When you are trying to play the video is the laptop running on intel driver? I see it is Intel Nvidia graphics so it is an Optimus setup?


Hi @endeavourosuser

Video is working fine on my installations of EndeavourOS. So it is not something related to the OS but to your particular setup. Therefore I have changed the title of the topic to better reflect this. I hope you don’t mind. Good luck with your troubleshooting!

Could also be a pulseaudio/pipewire issues.

I don’t know if I can call this a solution, but rather than it working after restarting, I went away from my pc for 8 hours, in which time my bluetooth headset automatically disconnected, the screen was locked during this time if that made a difference, and came back to see that everything listed in the original post was working desirably.
Noting that the screen was locked and a bit of time was taken away from the computer when this problem, a relatively common one on this as well as other distros on my pc, was resolved, I’ll wait until I have the problem again and try some of these steps to see if they can provide a faster solution than a reboot. If in the meantime someone finds a legitimate solution I may mark that as the thread-ending solution instead.

Your PC needs apparently 8 hours and a couple of reboots to work desirably :wink:

Good to know that your issue is resolved!

1 Like

Don’t see anything in the hardware that i would think to cause this issue. Has to be the install. Bad download or ISO creation. With that hardware should work well.

I got the problem again(around the same time of day as the problem had occured the day before), and after lock the screen and reentering, the problem remained, so I used the browser to do something unrelated to video/audio for a few minutes, tried youtube again and got the same result.

I then closed the browser, locked the screen, disconnected the bluetooth headphones, and then reentered the pc and tried youtube on firefox. YouTube was working as I wanted it to after these steps.

This leads me to believe there is a problem with the bluetooth drivers on my computer or a problem with the sony WH-1000XM4 bluetooth headset.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.