Video doesn't play in web browsers

I was thinking this was a browser issue, as videos I have on disc as files play fine, in any player. But I see now that videos will not play properly(or at all) in either Firefox or Google Chrome browsers.
I’m not sure how to troubleshoot this, any help would be appreciated.

Can you explain what you mean in more detail?

For example, what videos specifically? Youtube, netflix, a physical DVD/BD? Also, what happens when you try to play the videos?

Videos files on my drive that I play with mpv player or VLC work fine, it’s online videos like Youtube or Vimeo videos that won’t start playing, tried both Chrome and Firefox, same situation with each.

I have a somewhat larger issue now with EOS, I thought maybe I could solve this by installing the Nvidia driver available in Pamac. Well, that didn’t go as planned. Right now I’m in Artix, which is on the same machine as the EOS install, but I’m going to reboot and bring up a TTY in EOS and work on getting back to the GUI.
Looks like choosing a different image worked, now I can figure out how to undo the video driver mishap.

If you want to install the nvidia drivers, install nvidia-inst and use that to install the drivers.

1 Like

Thanks, I just finished installing the invidia driver correctly with nvidia-inst, as mentioned in the Wiki.
So right now I’m back in my initial EOS initramfs, along with the nvidia 535.104.05 driver. Before I borked the GUI I’m not really sure, must have been using the nouveau driver, maybe that was the problem with viewing videos in a web browser…? Right now videos are running as they should, in Firefox and Chrome.

1 Like

I spoke too soon, videos not playing in a web browser. Could it be some network setting? I haven’t changed anything manually, myself. ???

I thought I’d use a different DE from my usual MATE. Install Budgie, never used it before. So far, video is playing as it should. I don’t know what the problem could be in MATE, if in fact there “is” an abnormality. Mate is my ‘go to’ DE, all my other machines run it without issue. Edit: Budgie and Cinnamon weren’t my cup of tea, wanted to return to MATE but there was no MATE option at login.

I always want to know “why”, but I guess some things are just “unknowable”. Reluctantly I resorted to a reinstall of EOS, which didn’t teach me anything, but at least was expedient, so that I could move forward.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.