Video does not stream over SMB share but works on NFS

Weirdly enough, that is exactly what is happening. I seem to have some movies I was streaming off my Synology NAS on my local network and once I start playing the file, it quickly exits after a few seconds of playback. VLC, and mpv does the same thing, and the error messages are not helpful, eg. “Cannot play file” etc.

Found out it was Samba which is the culprit here, I turned on NFS on my NAS, then streamed the same movie without any issue on both VLC and mpv. I don’t have an issue using NFS for my shares but what would cause the issue of not being able to watch videos even though I can see all my files and shares via SMB. Is it something to do with the underlying protocol and linux?

Does your Samba user have the correct permissions set?

Yes correct permissions are set, I’m thinking any linux, not EOS specifically does not like streaming video data over SMB and would prefer NFS instead. If I copy the video file directly to the local hard drive via SMB and play it afterwards, it also works just fine. I guess I just find this strange.

SMB should work fine over Linux. To confirm, I tried streaming a video file over SMB now and I have no problem doing so. Most of the time when I have trouble with SMB it is a result of lacking permissions, even when it seems like the correct ones are set. Since you have NFS working I’d use that, but If you want to use SMB I’d double check permission requirements.

Does your problem affect all files or a specific video file?


Thanks, I’ve solved the issue, it seems it was the way Synology did the share and SMB didn’t like it. It had to be setup a specific way for Samba to work over Linux.

  1. Log in to your Synology Disk Station Manager and go to Control Panel. Choose File Services in tab SMB/AFP/NFS and select SMB service.
  2. Provide name of your Workgroup. Remember name of field Mac (Finder): smb://nas_name.
  3. In Advanced Settings you can choose maximum and minimum SMB protocol (if are not sure what to select choose maximum version to SMB3 and minimum to SMB1).
  4. Additionally switch Transport Encryption Mode to Auto and select Enable Opportunistic Locking. Now you are ready to mount folders on Linux.

Setting maximum version to SMB3 was the setting that I needed to get this to work correctly.

Glad you figured it out!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.