VGA monitor display resolution not recognized

Everything worked just find till last update(did it from pamac). The extended dysplay resolution is 1920x1080 but after update highest it can go is 1024x768.
I tired

cvt 1920 1080
xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync  
xrandr --addmode VGA1 1920x1080_60.00
xrandr --output VGA1 --mode 1920x1080_60.00

the message pops:

xrandr: Configure crtc 1 failed

I can’t roll back since i did not make backup, never tought of it till now :frowning:
Was looking trough forums and arch wiki, did not find solution, also uninstalled xf86-video-intel, did not help, installed it again, nothing…
Here is my inxi -Fxxxz

System:    Kernel: 5.15.2-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2
           info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux
Machine:   Type: Laptop System: FUJITSU product: LIFEBOOK E734 v: 10601583233 serial: <filter> Chassis: type: 10
           v: LIFEBOOK E734 serial: <filter>
           Mobo: FUJITSU model: FJNB26F v: M3 serial: <filter> UEFI: FUJITSU // Phoenix v: Version 1.17 date: 09/26/2014
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 Plus serial: <filter>
           charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: Quad Core model: Intel Core i7-4712MQ bits: 64 type: MT MCP arch: Haswell rev: 3 cache: L2: 6 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36734
           Speed: 797 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 797 2: 1627 3: 2274 4: 798 5: 802 6: 872 7: 798
           8: 965
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Fujitsu Limited. driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
           Device-2: Chicony FJ Camera type: USB driver: uvcvideo bus-ID: 3-12:9 chip-ID: 04f2:b3b4 class-ID: 0e02
           serial: <filter>
           Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: intel
           unloaded: fbdev,modesetting,vesa resolution: 1: 1366x768~60Hz 2: 1024x768~60Hz s-dpi: 96
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 21.2.5 compat-v: 3.0
           direct render: Yes
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Fujitsu Limited. driver: snd_hda_intel
           v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c class-ID: 0403
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Fujitsu Limited. driver: snd_hda_intel
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-arch1-1 running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Ethernet I217-LM vendor: Fujitsu Limited. driver: e1000e v: kernel port: 3080 bus-ID: 00:19.0
           chip-ID: 8086:153a class-ID: 0200
           IF: enp0s25 state: down mac: <filter>
           Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel bus-ID: 02:00.0 chip-ID: 8086:08b1 class-ID: 0280
           IF: wlan0 state: up mac: <filter>
           Device-3: KYE Systems (Mouse Systems) GF3000F Ethernet Adapter type: USB driver: hid-generic,usbhid
           bus-ID: 3-10.3:8 chip-ID: 0458:6001 class-ID: 0301
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-3: wwp0s20u11c2i12 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 3-8:4 chip-ID: 8087:07dc
           class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled rfk-block: hardware: no software: no
           address: see --recommends
Drives:    Local Storage: total: 465.76 GiB used: 222.86 GiB (47.8%)
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: 3B6Q scheme: GPT
Partition: ID-1: / size: 456.88 GiB used: 222.86 GiB (48.8%) fs: ext4 dev: /dev/sda2
           ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 243 Uptime: 11m wakeups: 3 Memory: 15.51 GiB used: 3.05 GiB (19.7%) Init: systemd v: 249 Compilers:
           gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1421 Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.07

I hope someone can help me :slight_smile:

I just tried my brother’s monitor over dp and is working perfectly fine, but my vga doesn’t. What could that be?

Also tried

cvt -r 1920 1080
xrandr --newmode "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync
xrandr --addmode VGA1 1920x1080R 
xrandr --output VGA1 --mode 1920x1080R

The resolution went to 1920x1080, but the edge touching the laptop screen was cut off and resolution lasted till next reboot/logout, then everything went back to not haveing higher resolution than 1024x768
I also dont have /etc/X11/xorg.conf file

I tried removing laptop from dock pluging VGA into it’s own VGA port, everything was find. Moved it back on dock, pluged it in dock’s VGA port again with changed settings (to 1920x1080), everything is working as it should be. Mabe its something wrong with dock, will pay more attention. I’ll mark it as solved,
but the strange thing is that all happend after the after-update reboot :thinking:
Mabe someone will have some explanation,…or not xD

I don’t have any explanation other than some of these docks seem to cause these strange issues. It’s happened with others too with multiple monitors. Glad it’s working now.

1 Like

Sometimes hardware ain’t what it’s cracked up to be!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.