VCV Rack is a black empty window

Hi.
Some time ago VCV was working right since the previous version, but I don’t know if I deleted something or maybe after one EndeavourOS update VCV became a black window, I was waiting the new VCV version, I thought it was going to change, but it is the same black window, this is only in Plasma, it is working perfectly in Gnome.

I tried: deleting the user folder, installing from AUR.
I already asked to VCV, but they don’t know what happens and they are looking for a solution.

Thank you :slightly_smiling_face:

Here is the log file.
log.pdf (24.2 KB)

This might point to the compositor - try some different settings in KDE (or e.g. disable the compositor) to see if this changes things.

Thank you!
I think I don’t use any compositor, how can I check that?
All Kwin scripts are disabled.
There are no window rules.

what build do you have installed?
yay -Qs vcv

I use the portable version (is the right terrn) I run it from the folder and is the 2.0.5

log do not show any error or missing libs… but could be that.

1 Like

Look in the KDE settings (the Window Manager section I think?)

1 Like

If qdbus org.kde.KWin /KWin supportInformation gives you any output, you could grep for Composit.

On Kubuntu 20.04 (with Plasma 5.18.5), I get:

> ~ $ qdbus org.kde.KWin /KWin supportInformation | grep -i compos
Composite: yes; Version: 0x4
compositingMode: 1
useCompositing: true
windowsBlockCompositing: true
Compositing
Compositing is active
Compositing Type: OpenGL
> ~ $ 

I don’t know if the above code works on the latest Plasma.

(The toggle to turn on/off compositing in X11 is Shift+Alt+F12.)

2 Likes

Thank you!
Is not active.
I’m using the default theme, icons, style, decorations, there are not any desktop effects, no window’s rules.

1 Like

Does it make a difference if you enable compositing?

GNOME has compositing enabled by default.

1 Like

Thank you.
No, there is no difference

1 Like