Using Windows (Super L) key for Whisker menu AND tiling shortcuts

Hi all, I’m a new Endeavour convert from Manjaro. I’m running XFCE as my DE (just as I did with Manjaro), but I’m having a weird time trying to replicate my keyboard shortcuts on Endeavour.

I want to be able to use just the Windows (Super L) key to open the Whisker Menu, as well as using Super L + [arrow key] to maximize/minimize/tile my windows. However, with Endeavour, if I set the window-specific shortcuts in the Window Manager, and then set Super L to xfce4-popup-whiskermenu in Keyboard → Application Shortcuts, the latter will override the arrow key shortcuts, preventing them from doing anything. This worked fine for me in Manjaro, so I’m wondering if this is also possible in Endeavour.

You might find useful this post from the old Manjaro forums:

https://archived.forum.manjaro.org/t/small-xfce-question-about-superkey-something-doesnt-work/61229/4

My instructions there should be relevant in EndeavourOS, as well:

After following these instructions, you’ll observe the following:

  • The Super keys (when pressed alone) open the Whisker menu, just as they do now.
  • Other keybindings with the Super key (like Super+E and Super+D) work as expected and do not open the Whisker menu.

First, install xcape:

sudo pacman -S xcape

Next, in the Session and Startup app, go to the Application Autostart tab and add this autostart task:

Name: xcape
Description: Map Super Keys to Alt+F1
Command: /usr/bin/xcape -e 'Super_L=Alt_L|F1;Super_R=Alt_L|F1'

Next, in the Keyboard app, go to the Application Shortcuts tab and remove both of the xfce4-popup-whiskermenu shortcuts (both Super R and Super L).

Still on the Application Shortcuts tab, add a new shortcut:

Command: xfce4-popup-whiskermenu

Then click OK. When prompted for the shortcut key, press Alt+F1.

Finally, log out and log in again, and you’re done.

3 Likes

Thank you so much, that worked perfectly.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.