User picture?

I can’t add a picture of my user in Gnome. I have allways manage that erlier, is there à bug of some kind?

Can you explain in more detail? Why can’t you add a picture? What are the specific steps you are following? Are you getting an error?

I go to settings and then user click on the circle then browse to my user picture and then add but nothing happens, I have done this a lot of times and it have always work.

can you try adding the picture to users home dir and rename it to .face ?

Ok I try that later.

Thanks

This is due to a bug in accountservices packages. will be fixed in 22.04.64 or newer.

seems this:

local/accountsservice 22.04.62-2
    D-Bus interface for user account query and manipulation
3 Likes

seems to be the same issue on plasma too!


Error on saving the Changes
But putting an avatar in png at home folder and rename it to .face is working here…

4 Likes

same on GNOME:

2 Likes

I can confirm this.

2 Likes

Another case where changing a file directly is king over a GUI :wink:

5 Likes

This only changes it in the settings, in the menu, lockscreen and login there is still no profile picture shown

true :wink: in Plasma it works for login screen in GNOME not …
trick 17?
sudo cp /home/joe/.face /usr/share/pixmaps/faces/joe.png
and it is available as one of the default pictures :wink:

I’m using plasma but I’ll give it a go that way now

/usr/share/plasma/avatars would be the one for plasma ?

Cool, was just about to post I was getting an error from the other command

but does not do the trick also on plasma :wink: it fails the same way also for the default avatars in the settings…

1 Like

Just noticed that, all good, i only ever see it when I log in anyways.
However I still cannot get it to change for the menu, login etc
It only changes in the settings for me with the original method posted, even after a reboot

i hacked it it seems the issue is with the service file for AccountsService:
sudo nano /usr/lib/systemd/system/accounts-daemon.service

this is set to
PrivateTmp=true
setting it to:
PrivateTmp=false
and reboot will solve it :wink:

1 Like

Cool, I’ll give a go soon