Use same NTFS drive in Linux and Windows

Hello,
I have a desktop machine with windows and Linux (I swap the drives so I don’t have a dualboot).
I also have a third drive permanently installed so I can use the same data in both operating systems. This drive is a NTFS drive, but if I want to mount it I get the following error message:

[man@man-allseries ~]$ sudo mount -t ntfs /dev/sda1 /mnt
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)
Could not mount read-write, trying read-only

After I type the following, I can properly mount it:

sudo ntfsfix /dev/sda1 

Is this the correct method, or will I break something in the long run?
Can i properly mount it in fstab?

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

If I remember correctly this issue arises when there is a hiberfil.sys file put by Windows on NTFS partitions. You could boot into Windows and try to delete this file and perform a proper shutdown.
Here is one article how-to:

Please do some research on your own as well. It’s been a while since I shared a NTFS partition between Windows and Linux, so… :wink:

Do you also have ntfs-3g installed.

I think the ntfs3-dkms from AUR is the recommended package?
Or maybe the new ntfs module is already in the latest kernel 5.15?

https://wiki.archlinux.org/title/NTFS

Please correct me if I’m wrong.

Yes. I checked it with:
pacman -Qi ntfs-3g
And I dont get an error.

I also found that I should shutdown while pressing the shift key, with shutdown \s \f or disable fastboot.
I will try them in that order but I dont want to disable fastboot for obvious reasons.

https://askubuntu.com/questions/462381/cant-mount-ntfs-drive-the-disk-contains-an-unclean-file-system
https://www.howtogeek.com/349114/shutting-down-doesnt-fully-shut-down-windows-10-but-restarting-it-does/

I don’t have that one installed on my system. I have ntfs-3g

Looks like the new ntfs3 is not fully available:

Note: Paragon has not yet released userspace utilities for NTFS3.

in the NTFS link above.

If you go into Windows and turn off the fast start up feature which uses hiber file. I think you won’t have this issue. This is not the fast boot feature in the Bios. This is in Windows under power options.

Yes,
here are more options:
shutdown while pressing the shift key, with shutdown \s \f or disable fastboot.
I will try them in that order but I dont want to disable fastboot for obvious reasons.

https://askubuntu.com/questions/462381/cant-mount-ntfs-drive-the-disk-contains-an-unclean-file-system

Well i don’t use hibernation. Obvious reasons.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.