Use only intel graphic card

Hi,
I’ve recently installed endeavour os, and I have some issues about graphic card. I have two card: one nvidia and an intel one. I would like to use only the intel card in order to a better battery life.
Currently, the nvidia card can is running with nouveau driver(see foto): I tryed to blacklist nouveau, but I noticed that the battery life got worse.
Thanks for all help.

In a hybrid/optimus laptop like that it won’t automatically leverage the dedicated GPU in most cases. It usually works the opposite. You have to do something special to get it to use GPU.

That being said, typically that hardware isn’t a full dedicated GPU as in a desktop. They are generally integrated together internally. Sometimes the internal monitor/external video ports are wired to the nvidia gpu and other times the intel one. However, I think it is much more common for them to connected to the intel gpu.

Either way, I think you are fine to leave the nouveau driver enabled. That being said, I am not an expert by any means on these setups so maybe someone more familiar will chime in.

@giovanni
I agree with @dalto your hybrid set up is most likely running on Intel. In order to switch graphics normally you need to install optimus-manager otherwise it will run only on Intel graphics. If you install the following it will give you more info.

sudo pacman -S mesa-demos xorg-xdpyinfo

Then run and post the output again with

inxi -Ga

1 Like

hey there
my setup is kinda similar to you

Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel 
  Device-2: NVIDIA GM107 [GeForce 940MX] driver: nvidia v: 470.57.02 
  Device-3: Realtek HD WebCam type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.12 driver: loaded: modesetting,nvidia 
  resolution: 1: 1920x1080~60Hz 2: 1400x1050~60Hz 
  OpenGL: renderer: NVIDIA GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 470.57.02 

and i use THIS to switch between intel and nvidia. works perfect for me
helpful commands :point_down:
optimus-manager --switch nvidia --no-confirm for switchting to nvidia
optimus-manager --switch integrated --no-confirm for switching to intel
optimus-manager --status to see which mode its running

3 Likes

There some things to try if you want to use only Intel.
One is keep blacklisting nouveau, and either install or uninstall package xf86-video-intel (and reboot). Some machines need the driver package, and others work better with the driver included in the kernel.

But before you start playing with the Intel driver, be sure you have an installer USB drive available in case it does not boot. Then you can undo the changes.

if you don’t need the dedicated GPU at all you can disable it in BIOS. that is the most reliable method you can use as it decreases the overall system’s complexity.

1 Like

While I am sure that some do, none of the hybrid/optimus laptops I have had my hands on had the ability to disable the dGPU in the bios.

Hmm, I’m fairly sure most laptops should have that. But it might be hidden. At least all laptops since 2012 I have tinkered with had hidden aka advanced settings that required a combination of keys to be pressed so this advanced settings can be displayed. On my current laptop I have disabled the dedicated graphics, but I remember the setting was non-intuitively named.

https://wiki.archlinux.org/title/Hybrid_graphics#Using_acpi_call

Nvidia optimus laptops I have used do not have this setting.

This is the way