"USB Wireless Adaptor"

This is new to me so any help is much appreciated.
lsusb
gives me “Realtek Semiconductor Corp. 802.11ac NIC”
Do I need to install a driver?
Can someone please help me get wireless on my computer.
I know this is not much to go on but, will provide what ever is needed.
Have always used ethernet. So this is a new learning experience.

The name says nothing - the preceding ID however will reveal much more information when you search for it.

Example

Bus 001 Device 014: ID 148f:761a Ralink Technology, Corp. MT7610U ("Archer T2U" 2.4G+5G WLAN Adapter

Thanks for your reply.
I hope this is what you relating to.

Bus 005 Device 002: ID 0bda:c811 Realtek Semiconductor Corp. 802.11ac NIC

Edit, no it's not rtl8821ce, it's rtl8821cu

This appears to be the rtl8821ce chip, so

$ yay -Ss rtl8821ce
aur/rtl8821ce-dkms-git 1.0.5.r36.gca4abd8-1 (+29 1.19) 
    rtl8821CE driver with firmware

That’s probably the driver you need.

I have installed the driver, but no idea what to do now!
I’m on kde desktop.
I assume there must be some steps to navigate.
What am I looking for lsmod

Reboot, then look for wifi settings in the KDE network settings.

If this was the correct driver for the chipset then it will “just work” - assuming the wifi is turned on?

Nothing in my network settings. It’s a new computer so could be something in bios maybe. Think I might have purchase a internal wireless card!
Thank you for your time.
What might be best for Linux?

I think you need this module

rtl8821cu-dkms-git
1 Like

Weird. The first search I did for the ID came up with ce, now I search again it comes up with cu. :confounded:

@ricklinux Well I installed rtl8821cu-dkms-git. rebooted, checked network and wireless network was there!! great, but when I put in the password seems to timeout and ask for the password again.
So close. Have tried on other computer with windows and no probs.
Any ideas anyone?

I don’t know why that would be happening? :thinking:

Maybe someone can make something of this
“journalctl -f”

Apr 15 02:05:24 daves-comp NetworkManager[497]: <info>  [1649952324.2483] device (p2p-dev-wlan0): supplicant management interface state: associating -> associated
Apr 15 02:05:25 daves-comp NetworkManager[497]: <warn>  [1649952325.0923] device (wlan0): Activation: (wifi) association took too long
Apr 15 02:05:25 daves-comp NetworkManager[497]: <info>  [1649952325.0924] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Apr 15 02:05:25 daves-comp NetworkManager[497]: <info>  [1649952325.0925] sup-iface[10d20d1bc307991f,0,wlan0]: wps: type pbc start...
Apr 15 02:05:25 daves-comp wpa_supplicant[1088]: wlan0: CTRL-EVENT-DSCP-POLICY clear_all
Apr 15 02:05:25 daves-comp NetworkManager[497]: <warn>  [1649952325.0927] device (wlan0): Activation: (wifi) asking for new secrets
Apr 15 02:05:25 daves-comp NetworkManager[497]: <info>  [1649952325.0936] device (wlan0): supplicant interface state: associated -> disconnected
Apr 15 02:05:25 daves-comp NetworkManager[497]: <info>  [1649952325.0936] device (p2p-dev-wlan0): supplicant management interface state: associated -> disconnected
Apr 15 02:05:25 daves-comp wpa_supplicant[1088]: wlan0: WPS-PBC-ACTIVE
Apr 15 02:05:25 daves-comp NetworkManager[497]: <info>  [1649952325.0995] device (wlan0): supplicant interface state: disconnected -> scanning
Apr 15 02:05:25 daves-comp NetworkManager[497]: <info>  [1649952325.0995] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> scanning```

Please use code tags around what you post so it’s easier to read.

Edit: You can use the 3 backticks ``` before and after or 3 tilde ~~~ before and after what you post. They are both on the same key. Or you can use the Preformatted text button in the menu here i think.

Edit2: You can just edit the post with pencil below it and add the code tags.

ok Haven’t worked that out as yet.
Need to do some reading !
Thanks for that info @ricklinux

How far is your PC from the access point? Is there a good enough signal to allow a connection? Have you tried disabling MAC address randomisation, if it’s active?

Keep in mind this chip uses 2.4 Ghz and 5.0 Ghz so maybe try one one or other. I can do that in my WiFi connection on KDE under BSSID.

@jonathon Im only 10ft away.
“disabling MAC address randomisation”
How do I do that?

I think you can right click on your network icon and configure networks.

Edit: Or go to settings connections.

I have 2 possible connections.The 2nd has 5GHz. Have tried both.
In network connections I have no BSSID

Are you able to set the password and save it in the connection here? Then try to connect.