USB peripherals not working after hibernation

Hey, this is my first go with Linux and so far I love it.

I have followed encrypted/snapshot installation guide to install EOS. Everything is working beautifully, except for one minor thing: after waking up from hibernation (suspend to hard drive) my external keyboard/mouse are not working. I tried multiple USB ports and all of them do not respond. To be more specific power is restored to devices (RGB turns on) for a brief moment when booting then it is lost. The only thing that solves this is rebooting. I scourged the internet for solution but could not find anything so I am asking EOS forum community for help.


Here is latest boot journal log.

Hardware info

Here is my hardware information

Other information that might be useful

I am using USB hub to connect multiple devices.

Thank you for any kind of help :smile:

Welcome to the forum. Any reasons not using suspend instead of hybernate? To my knowledge, hybernate never worked that well on Linux. There maybe also some troubleshooting in the arch wiki.

I stopped using hybernate about 10 yr ago, and rarely reboot my system. I live on suspend :wink: also use a dock with USB mouse, keyboard and screen, no connection issue.


Which model? Most of them work well on Linux but some of them not that much

Thanks for reply, when researching linux at some point I just geeked out and learned the difference between sleep and hibernate :laughing: So, I choose hibernate if I leave laptop for longer time and want to save that little amount of energy. Although, waking up from hibernation is terribly slow compared to suspend so there is that. Of course, if I am unable to fix this problem I’ll just use suspend instead as it is working correctly.

Hub that I am using is cheap Deltaco UH-484.