USB Mouse trouble

I have a Mionix Castor usb mouse, and sometimes when I boot, the device cannot be initialized and the following error appears (from dmesg)

Jun 04 22:30:13 michael-pc kernel: usb 1-7: new full-speed USB device number 4 using xhci_hcd
Jun 04 22:30:14 michael-pc kernel: usb 1-7: string descriptor 0 read error: -75
Jun 04 22:30:14 michael-pc kernel: usb 1-7: New USB device found, idVendor=22d4, idProduct=1316, bcdDevice= 2.00
Jun 04 22:30:14 michael-pc kernel: usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jun 04 22:30:14 michael-pc kernel: usb 1-7: can’t set config #1, error -71

Everything I have been able to find on this seems to indicate hardware failure (bad connector, cable, etc). This doesn’t happen with any other devices, so I am assuming that it is only the mouse, if it is indeed hardware failure.

But before I go out and get a new mouse, does anyone else have any insight into what this might be?

Not an EndeavourOs specific issue, I think. But I have visited nearly every Google link on this issue, and I’m out of ideas other than bad hardware.

Running on linux-lts (5.10.42-1-lts). I have tried this on the current 5.12 kernel, zen, and xanmod-lts, and same issue every time but with varying frequency of occurrence. Seems to happen more on standard lts.

1 Like

Maybe a stupid question: Have you tried unplugging and replugging your mouse? My Logi M705 wireless mouse sometimes becomes very sloooooow when scrolling. :grimacing: So a quick removal of the USB dongle and reconnect fixes the problem for me. :nerd_face:

In addition to re-plugging, can you try different USB ports?

1 Like

Maybe a stupid question: Have you tried unplugging and replugging your mouse?

No worries. Yeah, unplugging and plugging back in fixes it immediately, every time. But I really want to know what is causing the issue to begin with, as it is super inconvenient to crawl under my desk and replug the mouse when it happens :rofl:

I actually just end up rebooting the machine via terminal right after login, and the mouse is usually working then. It’s super random when it happens.

I have tried different USB ports, but it happens on any, and it doesn’t matter if it is usb 2.0 or 3.0

Do you have an on/off switch on your mouse? That could make “re-plugging” easier… :sweat_smile:

Maybe some USB or mouse related kernel parameter could do the trick? Worth searching anyway. Because the mouse works, it could be e.g. a timing issue in the initialization.

And to analyze it, could you show some journal logs? See for details.

What does lsusb show.

Edit: Also check lspci -v to see what your usb controller is. Then check sudo dmesg to see if you can see any error message related to the mouse. It may be that it doesn’t recognize the host controller. In otherwords the mouse may not talk properly to the controller and isn’t recognized properly.

Edit: The OHCI and UHCI controllers support only USB 1 speed devices (1.5 Mbit/s and 12 Mbit/s), and the EHCI only supports USB 2 devices (480 Mbit/s). The xHCI architecture was designed to support all USB speeds, including SuperSpeed (5 Gbit/s) and future speeds, under a single driver stack.

Edit: I edited the command above should have been lspci -v

As you can see my usb controller is the following.

2f:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Matisse USB 3.0 Host Controller (prog-if 30 [XHCI])
	Subsystem: Micro-Star International Co., Ltd. [MSI] X570-A PRO motherboard
	Flags: bus master, fast devsel, latency 0, IRQ 121, IOMMU group 30
	Memory at fcc00000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: <access denied>
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci

Thank you all. I’ll pull journalctl the next time it happens.

Here’s lspci -v:

00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10) (prog-if 30 [XHCI])
DeviceName: Onboard - Other
Subsystem: ASRock Incorporation Device a36d
Flags: bus master, medium devsel, latency 0, IRQ 131
Memory at a3720000 (64-bit, non-prefetchable) [size=64K]
Kernel driver in use: xhci_hcd
Kernel modules: xhci_pci

and lsusb:

Bus 002 Device 002: ID 174c:3074 ASMedia Technology Inc. ASM1074 SuperSpeed hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 22d4:1316 Laview Technology Mionix Castor
Bus 001 Device 003: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 001 Device 002: ID 174c:2074 ASMedia Technology Inc. ASM1074 High-Speed hub
Bus 001 Device 008: ID 8087:0aa7 Intel Corp. Wireless-AC 3168 Bluetooth
Bus 001 Device 007: ID 04d9:0295 Holtek Semiconductor, Inc. USB-HID Keyboard
Bus 001 Device 006: ID 1235:8202 Focusrite-Novation Focusrite Scarlett 2i2 2nd Gen
Bus 001 Device 005: ID 17a0:0240 Samson Technologies Corp. Go Mic Connect
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This looks like the mouse here.

Edit: Could be a usb auto suspend issue also. Is the motherboard Bios\UEFI firmware up todate? You could check the Bios version and date for your motherboard.

I have the same problem on Manjaro with a wireless Logitech mouse. I mentioned Manjaro because i think this is either not distro related or something arch-specific. just about every few days or so, the mouse would not initialize on boot so i have to unplug it and plug it in again for it to work. Turning the mouse on and off has no effect. I never was curious enough to fire up any diagnostic tools, so no logs from me. Just wrote this to let you know the problem is most likely not the mouse itself, no need to rush out and buy a new one for this.

First of all, please encode terminal output and such in code tags (three backticks, enter, paste, enter, three backticks).

Have you got another machine to try the offening mouse on? If so is the behaviour different?
Have you got another mouse to try on the machine the problem occurs on? If so is the behaviour different?

I try to use as little wireless devices as possible. My mouse and keyboards are wired and i have switched lately to mechanical keyboard and mouse is higher end also. I have no issues normally but i have with the mouse using sway. :slightly_smiling_face:

Sorry for the delay in responding. The issue definitely seems to occur way less often on the xanmod kernel, so I have not yet been able to reproduce the issue. Once thing I did was disable the power delivery to the USB ports when the computer is off. I will see if that makes a difference.

I already turned off auto_suspend in the kernel parameters since I have a Focusrite that was constantly shutting off if there was no sound. I may have a BIOS update available, I’ll have to check into that.

Ah, I see. I hope it is not a kernel bug. But I fear it may be, as I ran Windows for years with this machine and this mouse, and never had this issue.

Thank you, I don’t post on forums very often, so I was not aware which setting to use. I will use that in the future.