USB mouse not working on laptop

So,i am new to Linux just joined Linux last week.i have tried both manjaro and endeavour os.And so far i am liking EOS.

but I am having issues when i use my usb mouse. its fine first of all when i boot up.but if i cloose the lid or it goes to lock mode after a time the mouse stops working.the mouse simply does not detect

i am using eos (gnome on xorg)(X11) on an Hp241g1(4gb ram) laptop.the mouse is connected to a usb 2.0 port i have tried all 3 ports.
mouse-logitech m90 wired mouse

Welcome to the forum! Have you ruled out some power saving option in the UEFI (BIOS) configuration? Is it just the mouse or everything connected via USB?

i havent tried anything else
i will try andd tell in a min
and tell me more about uefi settings please?

When you boot your computer, while the HP logo is displayed (before GRUB gets loaded), you can enter the BIOS setup by pressing some key. It’s specific to your motherboard, but it’s probably one of the following: Del, F10, Esc, F2, Tab

There you can look for power saving options that turn off USB, ACPI options, stuff like that… It’s specific to your motherboard, so I don’t know exactly what option to look for. Don’t touch anything having to do with date and time, overclocking (CPU frequencies), and booting.

TLP? As the laptop is going to sleep :thinking:

there were no such options

yes

Try tlpui and play with the settings - it is in AUR:

i even disabled usb auto spend nothing worked
(also read edit)

Update- there are 3 ports 2 of which are usb 3.0 and 1 is 2.0
when the 3.0 port works for mouse 2.0 doesnt and when when 2.0 works 3.0 doesnt

Does it start working if you un plug/re plug it?

no it doesnt

To enter Bios start laptop and quickly press esc key and then pressing F10 key.

You may be able to turn off usb autosuspend. You could try and see if it works by adding a kernel parameter in the default grub command line and updating grub.

usbcore.autosuspend=-1
1 Like

In addition to what @ricklinux posted, if you have the options to enable XHCI, EHCI and IOMMU in BIOS setup, enable them. Also try adding iommu=soft to your kernel parameters.

i dont have any of those options
i tried turning of usb core using tlp ui
it dont work

how to do that in terminal
pls tell
i play games it annoying

The first question is are you able to get into the Bios setup? Is that what you mean and there are no options that @Kresimir pointed out?

yes i am

To set a kernel parameter in the default grub command line. You can try one at a time or more at once.

sudo nano /etc/default/grub

In the line after “quiet” add the kernel parameters you want to try.

Example: GRUB_CMDLINE_LINUX_DEFAULT=“quiet iommu=soft usbcore.autosuspend=-1 loglevel=3 nowatchdog”

To save the file after adding the entry or entries.

ctrl + o then hit enter

To exit

ctrl +x

Then you need to update grub with the following.

sudo grub-mkconfig -o /boot/grub/grub.cfg

If the kernel parameters do not work then you can remove them using the same process and then update grub again with the last command.