USB Displaylink connection not detected

I had a working desktop system with 3 monitors connected for months without issue. Then the PCI slot on the motherboard seems to have developed an issue because multiple different AMD graphics cards will not work. Wierd errors that I don’t have time to troubleshoot more at the moment. So I bought a Startech USB3.0 to HDMI adapter because working with 2 monitors feels a bit like torture when used to 3. Its a dual boot system, so if I boot into Windows it works, so I know the USB device and HDMI cable are working fine.

So I can see the device via lsusb

[stevo@Dharma ~]$ lsusb | grep T6
Bus 002 Device 002: ID 0711:5601 Magic Control Technology Corp. T6 USB Station

The DisplayLink service wouldn’t start using the standard evdi package, but changing to evdi-git was successful, so thats working.

systemctl status displaylink.service
● displaylink.service - DisplayLink Manager Service
     Loaded: loaded (/usr/lib/systemd/system/displaylink.service; enabled; preset: disabled)
    Drop-In: /usr/lib/systemd/system/displaylink.service.d
             └─displaylink-connect.conf
     Active: active (running) since Sat 2024-02-03 02:55:56 CST; 11h ago
    Process: 823 ExecStartPre=/sbin/modprobe evdi (code=exited, status=0/SUCCESS)
    Process: 825 ExecStartPost=/bin/sleep 1 (code=exited, status=0/SUCCESS)
    Process: 870 ExecStartPost=/usr/bin/run_as_users_with_display systemctl --user --no-block start displaylink-connect.service (code=exited, status=0/SUCCESS)
   Main PID: 824 (DisplayLinkMana)
      Tasks: 14 (limit: 76779)
     Memory: 35.7M (peak: 38.0M)
        CPU: 16.565s
     CGroup: /system.slice/displaylink.service
             └─824 /usr/lib/displaylink/DisplayLinkManager

Feb 03 02:55:55 Dharma systemd[1]: Starting DisplayLink Manager Service...
Feb 03 02:55:56 Dharma systemd[1]: Started DisplayLink Manager Service.

However, the monitor is never detected or turns on, either via inxi, xrandr, arandr etc. I don’t have an Nvidia card installed, so I don’t have Nouveau, so thats not the issue. I see a previous post that used the Hyprland-displaylink-git package, but thats now an orphaned package. I don’t see anything in dmesg and I’ve tried rebooting

[stevo@Dharma ~]$ inxi -Ga
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: DP-1,HDMI-A-2 empty: HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:3e98 class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
    driver: X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris
    gpu: i915 display-ID: 0
  Monitor-1: DP-1 model: LG (GoldStar) E2742 built: 2011 res: 1920x1080
    dpi: 82 gamma: 1.2 size: 598x337mm (23.54x13.27") diag: 686mm (27")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-2 model: Philips PHL 322E1 serial: 1153 built: 2020
    res: 1920x1080 dpi: 70 gamma: 1.2 size: 698x393mm (27.48x15.47")
    diag: 801mm (31.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.5-arch1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL
    GT2) device-ID: 8086:3e98 memory: 61.05 GiB unified: yes display-ID: :0.0
[stevo@Dharma ~]$ sudo dmesg | grep -E 'udl|displaylink|evdi'
[    8.159448] evdi: [I] Initialising logging on level 4
[    8.159451] evdi: [I] Atomic driver: yes
[stevo@Dharma ~]$ lsmod | grep video
video                  77824  2 dell_wmi,i915
wmi                    45056  7 video,intel_wmi_thunderbolt,dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor,mxm_wmi

So any ideas as to what might be the issue here?

Have you gone through these troubleshooting steps?

https://wiki.archlinux.org/title/DisplayLink#Not_working_configuration

@steky9
Not sure if the Startech adapter is the problem but here is another that has the displaylink chip and works on linux according to the description if it’s available in your location.

https://www.amazon.ca/CableCreation-DisplayLink-External-Graphics-Compatible/dp/B07DWXWW63?th=1

Edit: Is this the one you have?

I’m no expert in this, but I don’t think those steps are applicable in this case.

I’m using Wayland, so I don’t think 3.1 or 3.10 applies. The monitor is not detected at all so 3.2 to 3.6 and 3.11 don’t apply. I don’t have any Nvidia cards installed and I don’t seem to have any nouveau packages installed so I don’t think 3.7 or 3.13 applies. Its not a suspend issue so no to 3.8, its permanently connected and I’ve tried rebooting so its not 3.9, I have only one monitor connected and its not a docking station so its not 3.12, and its a USB3.0 device plugged into a USB3.0 port and I’m not seeing any of the messages shown in dmesg so I don’t think 3.14 applies

This is the one I had. I’d be ok with changing if I thought it had a decent chance of successfully working

https://www.amazon.com/dp/B00H91BQ7Y?ref=ppx_yo2ov_dt_b_product_details&th=1

Edit: And its only now I see it says Linux not supported.

I’ll try get the one you linked instead and try again

This one is Displaylink certified but it doesn’t say it’s compatible with linux.

Edit: This one does say it works with linux.

https://www.amazon.ca/CableCreation-DisplayLink-External-Graphics-Compatible/dp/B07DWXWW63?th=1

:man_shrugging:

They have the displaylink chip on them. Not sure about the one you have as it doesn’t say anything about supporting displaylink.

Swapped in this new one as recommended, rebooted… and all works perfectly for now at least. Can mark this one as solved

https://www.amazon.com/CableCreation-DisplayLink-External-Graphics-Compatible/dp/B07DWXWW63?th=1

Got a few small other issues, but I’ll put them in the DE section instead.

Glad you tried that one i mentioned was linux compatible as opposed to the other StarTech that didn’t say it was compatible with linux. It may or may not have worked. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.