USB crash when bluetooth connected

Hi everybody,

I’m facing a very strange issue when using bluetooth with EndeavourOS/Archlinux. I’m able to search a device and to pair with, but once it is connected, it works for maybe 2-3 seconds, then none of USB devices work anymore… So no keyboard, no mouse, etc.

I have to remote my computer with SSH, then I could restart it.

I’m using a Lenovo Thinkcentre tiny m715q with embedded RTL8821ce bluetooth controller. But, I tried to disable it for using a Bluetooth USB dongle, and it is the same. I tried to connect some different devices (PS4 controller, mouse, speakers), and the result is always the same.

I don’t know what happen. Do you have any idea?


I investigated more deeply, and it seems that it is just a power issue. I use USB powered speakers and, because the bluetooth chip is also connected to USB, the power delivered by the computer is not powerful enough.

I use an external USB power intead and it works well.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.