USB audio not shown correctly

Hi all,

Hope you can help me with a cosmetic issue?

I have my EndeavourOS desktop connected via USB to some Audioengine 2+ active speakers. But somehow after an update the sound settings do not show the Audioengine 2+ anymore but some other device.

When I check Alsamixer the Audioengine 2+ is shown correctly, when I use lsusb the wrong usb sound device is shown. Somehow a Mpow HC5 Headset is shown, but I do not own that or have it connected…

Maybe I should mention that I have the Audioengine 2+ connected via the USB hub in my screen (with allows me to switch the whole setup to another computer with just one USB-C cable)

Any idea how I could fix this so that Audioengine 2+ is shown correctly instead of the incorrect Mpow HC5?

Hello and welcome,

Nothing wrong with that, lsusb shows the company which provides the chipset/firmware of your device, Cambridge Silicon Radio.

For example my USB DAC is Topping E50 and it shows like this in lsusb :

Bus 003 Device 003: ID 152a:8750 Thesycon Systemsoftware & Consulting GmbH E50

because Thesycon developed the firmware.

Thanks for your reply, but i was wondering af it used to be shown correctly. However, with an update at some point i ended up with the current situation. It’s also weird as the mpow is a Bluetooth headset, so quite different.
I do not fully understand how this change occurred. Hence my question.

1. Check PulseAudio Settings

sudo pacman -S pavucontrol

PulseAudio Volume Control (pavucontrol) Steps:

  • Open pavucontrol (pavucontrol in terminal).
  • Go to the “Output Devices” tab
  • Ensure that “Audioengine 2+” is selected as the output device and not the Mpow HC5
  • You might need to restart any applications that are currently using audio to apply the changes.

2. Check ALSA Settings

  • Use alsamixer in the terminal to ensure that the correct sound card (Audioengine 2+) is set as the default and that its volume levels are adjusted properly.

3. Verify USB Connection

Since your Audioengine 2+ is connected via a USB hub in your screen, make sure that the USB connection is stable. Sometimes, USB connections can become unstable after updates or due to power management settings.

  • Try connecting the Audioengine 2+ directly to a USB port on your computer instead of through the hub, to rule out any issues with the hub causing the device to not be detected correctly.

4. Restart PulseAudio Service

pulseaudio -k

5. Update System and Drivers

Ensure your EndeavourOS system and all related packages are up to date:

journalctl -xe

6. Remove Unused Audio Devices

If the Mpow HC5 continues to appear incorrectly, you can try removing its ALSA configuration files temporarily to see if that helps:

sudo rm /etc/asound.conf

7. Reset Audio Settings

As a last resort, you can reset your PulseAudio configuration to default settings:

mv ~/.config/pulse ~/.config/pulse.old

This command renames the PulseAudio configuration folder. PulseAudio will recreate it with default settings on the next restart.

After trying these steps, check if your Audioengine 2+ speakers are recognized correctly and if you can select them for audio output in your system settings or applications. If the issue persists, further investigation into system logs and possibly checking for specific driver updates might be necessary.

Thanks for your help!

@1. Pavucontrol unfortunately shows the Mpow

@2. Alsamixer shows the correct Audioengine 2+

@3. USB direct or via screen doesn’t give a difference

@4. Command not available?

@5. seems to give some errors, but not sure how to fix those?

Not sure to try 7 and 8 (what happened to 6?)
Any advise on how to fix the pipewire errors?

i find a tutorial how to trobleshoot pipewire:

or try this

Step 1: Verify PulseAudio Installation and Restart the Service

1. Install PulseAudio:
sudo pacman -S pulseaudio pulseaudio-alsa

2. Restart PulseAudio:

Restart PulseAudio: Since pulseaudio -k is not available, try using systemd to restart the PulseAudio service:

systemctl --user restart pulseaudio

If that command does not work, you can manually kill and restart PulseAudio:

killall pulseaudio
pulseaudio --start

Step 2: Check PulseAudio Configuration

1. Delete PulseAudio Configuration: Resetting PulseAudio settings to defaults can help resolve configuration issues:

rm -rf ~/.config/pulse

2. Check Default Sink: Ensure that the correct device is set as the default sink:

pacmd list-sinks | grep -e 'name:' -e 'index:'

2.5 Identify the index number of your Audioengine 2+ and set it as the default sink:

pacmd set-default-sink <index_number>

Step 3: Fix ALSA and PulseAudio Configuration Errors

1 Inspect System Logs: Use journalctl to check for any errors related to audio devices:

journalctl -xe | grep pulse

2 Update System Packages: Ensure all your packages, including audio-related ones, are up to date:

sudo pacman -Syu

Step 4: Manually Configure ALSA

Create a custom ALSA configuration file to force the system to recognize the correct audio device.

  1. Create or Edit the .asoundrc File: Open or create the .asoundrc file in your home directory:

nano ~/.asoundrc

2 Add Configuration for Audioengine 2+: Add the following configuration, adjusting the device index if necessary:

pcm.!default {
    type hw
    card <card_number>

ctl.!default {
    type hw
    card <card_number>

Replace <card_number> with the correct card number for your Audioengine 2+.

Step 5: Use aplay to Test Audio Output

Use aplay to test audio output and confirm that the correct device is being used:#

1 List Available Audio Devices:

aplay -l

2 Play a Test Sound:

aplay -D plughw:<card_number>,0 /usr/share/sounds/alsa/Front_Center.wav

Replace <card_number> with the appropriate card number.

Step 6: Additional Tools

Consider installing and using additional tools like pavucontrol-qt for more detailed control over PulseAudio:

sudo pacman -S pavucontrol-qt


  1. Restart PulseAudio using systemctl --user restart pulseaudio.
  2. Reset PulseAudio settings by removing the ~/.config/pulse directory.
  3. Check and set the correct default sink using pacmd.
  4. Update your system packages and fix any configuration errors by checking system logs.
  5. Manually configure ALSA if needed.
  6. Test audio output with aplay.

what you could try

try it on different system to check if the speakers works

reinstall your system

try it on windows/mac to check if the speakers works