USB 3 ports showing as USB 2 / slow speeds

how can i tell endevour to use usb version 3 on usb3 ports? all the speed are capped and here it shows that none are using usb3.

Hub 9 and 11 are are eSATA ports.

some general info

System:
  Kernel: 6.1.12-arch1-1 arch: x86_64 bits: 64 Desktop: Xfce v: 4.18.1
    Distro: EndeavourOS
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A97 EVO R2.0 v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2501
    date: 04/09/2014
CPU:
  Info: 6-core model: AMD FX-6300 bits: 64 type: MT MCP cache: L2: 6 MiB
  Speed (MHz): avg: 1402 min/max: 1400/3500 cores: 1: 1402 2: 1404 3: 1404
    4: 1400 5: 1400 6: 1405

and the

$ inxi -Jazy1
USB:
  Hub-1: 1-0:1
    info: Full speed or root hub
    ports: 5
    rev: 2.0
    speed: 480 Mb/s
    chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 2-0:1
    info: Full speed or root hub
    ports: 5
    rev: 2.0
    speed: 480 Mb/s
    chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-3: 3-0:1
    info: Full speed or root hub
    ports: 4
    rev: 2.0
    speed: 480 Mb/s
    chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-4: 4-0:1
    info: Full speed or root hub
    ports: 5
    rev: 1.1
    speed: 12 Mb/s
    chip-ID: 1d6b:0001
    class-ID: 0900
    Device-1: 4-5:3
      info: Apple Aluminium Keyboard (ANSI)
      type: Keyboard,HID
      driver: apple,usbhid
      interfaces: 2
      rev: 2.0
      speed: 12 Mb/s
      power: 500mA
      chip-ID: 05ac:024f
      class-ID: 0300
  Hub-5: 5-0:1
    info: Full speed or root hub
    ports: 5
    rev: 1.1
    speed: 12 Mb/s
    chip-ID: 1d6b:0001
    class-ID: 0900
    Device-1: 5-1:2
      info: Logitech G502 Mouse
      type: Mouse,HID
      driver: hid-generic,usbhid
      interfaces: 2
      rev: 2.0
      speed: 12 Mb/s
      power: 300mA
      chip-ID: 046d:c07d
      class-ID: 0300
      serial: <filter>
  Hub-6: 6-0:1
    info: Full speed or root hub
    ports: 2
    rev: 1.1
    speed: 12 Mb/s
    chip-ID: 1d6b:0001
    class-ID: 0900
  Hub-7: 7-0:1
    info: Full speed or root hub
    ports: 4
    rev: 1.1
    speed: 12 Mb/s
    chip-ID: 1d6b:0001
    class-ID: 0900
  Hub-8: 8-0:1
    info: Hi-speed hub with single TT
    ports: 2
    rev: 2.0
    speed: 480 Mb/s
    chip-ID: 1d6b:0002
    class-ID: 0900
    Device-1: 8-2:3
      info: SanDisk Extreme 55AE
      type: Mass Storage
      driver: uas
      interfaces: 1
      rev: 2.1
      speed: 480 Mb/s
      power: 500mA
      chip-ID: 0781:55ae
      class-ID: 0806
      serial: <filter>
  Hub-9: 9-0:1
    info: Super-speed hub
    ports: 2
    rev: 3.0
    speed: 5 Gb/s
    chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-10: 10-0:1
    info: Hi-speed hub with single TT
    ports: 2
    rev: 2.0
    speed: 480 Mb/s
    chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-11: 11-0:1
    info: Super-speed hub
    ports: 2
    rev: 3.0
    speed: 5 Gb/s
    chip-ID: 1d6b:0003
    class-ID: 0900

I checked the bios and everything about usb3 is enabled: usb2 legacy enabled, usb3 legacy enabled, and EHCI handoff enbaled

I also had that board 10 years ago, and it only had 2 USB3 ports + 2 that could be added as Front USB. So there is nothing wrong with the detection, the hardware is not capable of more.

You need to have Asmedia USB 3.0 Controller (Rear) set to [Enabled] - the other options are for legacy OS support. EndeavourOS is not legacy.

Not all of the ports are going to run usb 3.0 if the hardware isn’t usb 3.0 That particular board only has so many USB 3.0 ports. Others are usb 2.0

Thats right, 2 in front and 2 the back.
But the speeds connected to those ports are still around 40Mb/s

The inxi command shows all ports/hubs as version 2.0
Except for the two eSata (and legacy nusb1).

And under mint (and windows) I had full high speeds at the dedicated .usb3 ports.

So something is wrong at the software level.

And I’m gonna check again if there are more options, thanks

What does it show under lsusb

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 046d:c07d Logitech, Inc. G502 Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05ac:024f Apple, Inc. Aluminium Keyboard (ANSI)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 011 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 002: ID 0781:55ae SanDisk Corp. Extreme 55AE
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I also took some screenshot of the bios.



It’s showing them as usb 1.1, 2.0 and 3.0. I assume you know which ones are which on your computer. Other then that i don’t know why the speeds would be slow? How do you test that?

the ports showing up as usb 3.0 are bus 9 and 11 and those are eSATA .
I test them with a simple file transfer of large video file.
its quit confusing…

Do you have the eSATA disabled in the Bios? Maybe try?

Im gonna admit to my shame and say that i was using a cheapass usb-C cable with the external ssd…
fixed that, i got the usual usb3 speeds with my internal ssd buth the internal hdd was having none of it ( still capped at 70Mbs). For the backup hdd im using ntfs as fileformat
quick google search showed i had to modify /etc/fstab with ntfs-3g ( i was using the older ‘ntfs’) and ‘big_writes’

Now everything runs as usual.

thanks for troubleshooting with me :slight_smile:

2 Likes

Yes… I am a big believer in the difference in cables. I try to get certified cables that meet the specs. Glad you figured it out.

The new “ntfs3” driver is faster than ntfs-3g, you may switch to that if you wish. It isn’t stable though, in my experience.