Urxvt terminal displays icons too small

Hi everyone!
I recently stopped using the xfce4 terminal because I started using the urxvt terminal, I configured it, but there is one small problem: unlike the xfce4 terminal, the urxvt terminal displays smaller icons. I would like the urxvt terminal to display icons the same size as the xfce4 terminal.

xfce4 terminal:
xfce4 terminal

urxvt terminal:
urxvt terminal

Attached are the urxvt terminal settings:

URxvt.buffered: true
URxvt.borderless: true
URxvt.letterSpace: -1
URxvt.lineSpace: 0
URxvt.iso14755: off
URxvt.iso14755_52: off
URxvt.tabbed.title: true
URxvt.tabbed.title-bg: 8
URxvt.tabbed.title-fg: 7
URxvt.termName: rxvt-unicode-256color
URxvt.cutchars: '"'&()*,;<=>?@[]^{|}\:
URxvt.geometry: 50x13
URxvt.internalBorder: 20
URxvt.clipboard.autocopy: true
URxvt.keysum.M-c: perl:clipboard:copy
Urxvt.keysum.M-v: perl:clipboard:paste
URxvt.cursorBlink: false
URxvt.cursorUnderline: false
URxvt.savelines: 100000
URxvt.scrollBar: false
URxvt.scrollBar_right: false
URxvt.urgentOnBell: true
URxvt.depth: 32
URxvt.font: xft:Hack Nerd Font Mono:bold:size=11
URxvt.boldFont: xft:Hack Nerd Font Mono:bold:size=11
URxvt.perl-ext: -confirm-paste,default,matcher,url-select
URxvt.url-select.launcher: /usr/bin/xdg-open
URxvt.url-select.underline: true
URxvt.url-launcher: $BROWSER
URxvt.keysym.C-u: perl:url-select:select_next
!URxvt*inheritPixmap: true
!URxvt*transparent: true
!URxvt*shading: 100
Xft.dpi: 96
Xft.antialias: true
Xft.hinting: true
Xft.rgba: rgb
Xft.autohont:

Also attached are the xfce4 terminal settings:
2022-11-05-18:20:35-screenshot

2022-11-05-18:20:34-screenshot

2022-11-05-18:20:32-screenshot

2022-11-05-18:20:30-screenshot

2022-11-05-18:25:41-screenshot

2022-11-05-18:25:39-screenshot

If it is at all possible to change the size of the icons in urxvt terminal, please explain in detail what the problem is. Thank you all for your attention!

Hello,
I am not good at urxvt, but I’d increase the font size or check whether this helps in .Xresources
Urxvt.font: xft:Dejavu Sans Mono:pixelsize=15

I already tried this and unfortunately the icons are still the same small

Hello again,
Not knowing the constraints / (why urxvt) I made a limited investigation and concluded in Termite.
Simple config, better rendering of characters etc.
[DTermiteConfig]
(https://gitlab.com/dwt1/dotfiles/-/blob/master/.config/termite/config)
font = Hack Nerd Font Mono Bold 11 #modification

termite -c ~/.config/termite/config
2022-11-09-191324_415x181_scrot
P.S. Meanwhile I have installed i3. It’s pretty good.

wow, that’s smart, thank you very much!
hah, yes, wm-s its a cool thing)

I had an old config file for urxvt, installed urxvt, edited the file with the same font I use in terminator, had the same results, icons were smaller. I tried to increase the space between lines or between letters, no improvement.

The config I used (default Xft.dpi is 96) :

! Xft settings ------------
Xft.autohint:   0
Xft.dpi:        82
Xft.antialias:  true
Xft.rgba:       rgb
Xft.hinting:    true
Xft.hintstyle:  hintslight
Xft.lcdfilter:  lcddefault

! URxvt settings ------------
URxvt*saveLines:  8000
URxvt*geometry:  108x32
URxvt*scrollBar:  true
URxvt*scrollBar_right:  true
URxvt*scrollstyle:  plain 
URxvt.cursorBlink: 		 true
    
URxvt.font: xft:LiterationMono Nerd Font Mono-12:style=book
URxvt*boldFont: xft:LiterationMono Nerd Font Mono-12:style=bold
URxvt.letterSpace: 1
URxvt.lineSpace: 1

For those who still like urxvt these are my best ‘results’:
2022-11-11-204345_726x448_scrot
.Xresources ( xrdb -query )

*.font: xft:Hack Nerd Font:style=Regular:size=15
URxvt.font: xft:UbuntuMono Nerd Font Mono:style=Regular:antialias=true:size=16:minspace=False, xft:SauceCodePro Nerd Font:style=Regular:antialias=true:size=16:minspace=False, xft:DejaVuSansMono Nerd Font:antialias=true:size=16:minspace=False, xft:DroidSansMono Nerd Font Mono:antialias=true:size=16, xft:FuraMono NF:size=16:antialias=true:minspace=False, xft:RobotoMono Nerd Font:antialias=true:size=16:minspace=False, xft:Noto Sans Mono:antialias=true:felse=16:minspace=False, xft:Monospace:style=Medium:antialias=true:minspace=False
*.foreground: #fbf1c7
*.background: #000000
*.cursorColor: #ff3232
*.color0: #665c54
*.color8: #928374
*.color1: #ea6962
*.color9: #ea6962
*.color2: #a9b665
*.color10: #a9b665
*.color3: #e78a4e
*.color11: #d8a657
*.color4: #7daea3
*.color12: #7daea3
*.color5: #d3869b
*.color13: #d3869b
*.color6: #89b482
*.color14: #89b482
*.color7: #d4be98
.color15: #d4be98
urxvt.keysym.Shift-Control-V: eval:paste_clipboard
urxvt.keysym.Shift-Control-C: eval:selection_to_clipboard
URxvt.keysym.C-Down: resize-font:smaller
URxvt.keysym.C-Up: resize-font:bigger
URxvt.perl-ext-common: default,matcher,resize-font
URxvt.buffered: true
URxvt.borderless: true
URxvt.letterSpace: -2
URxvt.lineSpace: -1
URxvt.iso14755: off
URxvt.iso14755_52: off
URxvt.tabbed.title: true
URxvt.tabbed.title-bg: 8
URxvt.tabbed.title-fg: 7
URxvt.termName: rxvt-unicode-256color
URxvt.cutchars: ‘"’&()
,;<=>?@[]^{|}:
URxvt.geometry: 50x13
URxvt.internalBorder: 20
URxvt.clipboard.autocopy: true
URxvt.keysum.M-c: perl:clipboard:copy
Urxvt.keysum.M-v: perl:clipboard:paste
URxvt.cursorBlink: false
URxvt.cursorUnderline: false
URxvt.savelines: 100000
URxvt.scrollBar: false
URxvt.scrollBar_right: false
URxvt.urgentOnBell: true
URxvt.depth: 32
URxvt.url-select.launcher: /usr/bin/xdg-open
URxvt.url-select.underline: true
URxvt.url-launcher: $BROWSER
URxvt.keysym.C-u: perl:url-select:select_next
Xft.dpi: 96
Xft.antialias: true
Xft.hinting: true
Xft.rgba: rgb
Xft.autohint:

Note perl : clipboard : copy

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.