Upscayl application won't work on EOS but works on other distro?

Hi. I downloaded an AI tool named Upscayl that seems to work just fine on my dual boot of Debian on this same machine, but on EOS it doesn’t work. I see the following error. Anyone know why this might be or how to solve it? I cant figure it out. Thank you


Do you have a vulkan driver appropriate for your GPU installed (e.g. vulkan-radeon or vulkan-intel)?

Also when you say downloaded you mean the AUR version?


Have you tried the flatpak?

1 Like

Assuming this was using upscayl-bin from the AUR, looks like there are some issues with vulkan drivers on that version. It’s also flagged as out of date.
The flatpak version that @WiFiBills mentioned was working fine on my system using an integrated gpu last fall, specifically on Debian 12.

The appimage(from github) also work great on my end.

I tried the AUR, the Flatpak and the AppImage. All of them give me errors.

The AppImage gives this error.


Turns out I didn’t have vulkan-intel installed.

Thanks for the help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.