Upgrading with yay failing

Hi everyone,

I’ve been using EndeavourOS for like one year without any significant customization, and uprgading with yay stopped working few days ago. I don’t see anyone having the same errors, I guess it’s not failing for many people, but since I have all the defaults for yay, reporting it here as a bug.

There is a first error in my logs about a failing mirror, but this doesn’t seem to be an issue (maybe it’s related, I don’t know:

error: failed retrieving file 'endeavouros.db' from mirrors.42tm.tech : Connection timeout after 10001 ms
:: Starting full system upgrade...
:: Replace yad-eos with endeavouros/yad? [Y/n]

Then I find this error about openssl being corrupt, which aborts the upgrade:

:: Proceed with installation? [Y/n] Y
(350/350) checking keys in keyring                                                                                 [---------------------------------------------------------------------] 100%
(350/350) checking package integrity                                                                               [---------------------------------------------------------------------] 100%
error: openssl: signature from "Pierre Schmitz <pierre@archlinux.org>" is marginal trust
:: File /var/cache/pacman/pkg/openssl-3.0.7-4-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
 -> error installing repo packages

Deleting the downloaded package and trying again doesn’t seem to fix the problem, so I guess it’s corrupt in the server.

I couldn’t find documentation on what are the mirrors being used, or how to update the mirror list. Maybe just changing mirror would solve the problem.

If someone knows what’s going on, or has an idea on what could I checked, it’s very welcome. Thanks!

A number of possibilities come to mind - most of them involving mirror problems…

A first step might be to try:
sudo pacman -Sy archlinux-keyring
before trying a rerun - This will likely make the upgrade go OK, with the possible exception of the things from the EndeavourOS repo. Then, to get the EnOS repo going, you could rebuild its mirrorlist, or as a quick ‘fix’, just comment out the first entry in the file /etc/pacman.d/endeavouros-mirrorlist by placing a # in front of it. This should allow the second entry to work, and is the ‘fast’ workaround. Or, you could regenerate the mirrorlist completely - which should drop non-working entries automatically.

I forget the command for this, as I never need to change MY EnOS mirrorlist…(I run one, so I already which to choose!) - but it should be easy to find… :grin:


Thanks for the very fast answer @freebird54, running sudo pacman -Sy archlinux-keyring worked without problems, and rerunning yay -Syu after it still shows the mirror error, but not the openssl error, and the updated worked just fine.

I think I was missing that yay is a wrapper around pacman, I guess I had to look for info on pacman and not yay. Thanks a lot for the help!


simply not responding… it may has issues currently we will see .
run eos-rankmirrors to solve …