Updating gives warning about the installed perl interpreter

sudo pacman -Syu gives this warning:

WARNING: ‘/usr/lib/perl5/x86_64-linux-thread-multi’ contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
→ Run the following command to get a list of affected packages: pacman -Qqo ‘/usr/lib/perl5/x86_64-linux-thread-multi’

I run the command:

$ pacman -Qqo '/usr/lib/perl5/x86_64-linux-thread-multi'
imagemagick

These packages were updated:

Package (4)        Old Version   New Version   Net Change  Download Size

extra/imagemagick  7.1.1.29-2    7.1.1.30-1      0.93 MiB       8.64 MiB
extra/libxmlb      0.3.17-1      0.3.18-1        0.00 MiB       0.15 MiB
extra/taglib       2.0-1         2.0.1-1        -0.02 MiB       0.42 MiB
extra/yt-dlp       2024.03.10-1  2024.04.09-1    0.29 MiB       4.71 MiB

I appreciate your help to solve this problem. Thank you!

A bug report was already filed:

And a new version of imagemagick package ( 7.1.1.30-2) was uploaded about an hour ago; it should hit your mirror soon.

1 Like

Thank you @Stagger_Lee!
I looked at the bug report. Exactly the same issue as for me.

After you mention this, I updated again. You are right. There was an update for imagemagick again.
No warning this time. Problem solved.

1 Like

The sweetest words:

problem_solved

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.