Update Terminal question

EndeavourOS Linux x86_64
Kernel: 5.14.14-arch1-1
DE: Plasma 5.23.1
Right so my question is how can i have access to that type of terminal when you search for “UpdateInTerminal”
Screenshot of what i mean

The flameshot package doesn’t have a capital F.

If you post text output as text it’s easier to see what you’re referring to.

Edit: wait, that’s not what you’re asking about…

welcome @Zer0 here :enos:

:smiley: Thank you

But your question is not really clear to me …

Right so i can only access that style type on the left terminal (App called Updateinterminal) and right terminal is the default terminal, im typing to figure out how to make the left terminal as default.

So it is about the terminal app “style” the right one is the plasma default konsole… and I am not sure at the moment what are all supported terminals for update-in-terminal… it chooses the first one it finds from a list afaik… you can check by right clicking on the terminal and see what you got…


    # Show a terminal that is capable of supporting option -e properly. Empty if not found.
    # Requires: yad
    #
    # These terminal programs are known not to work with this program:
    #     - putty
    # The following terminals are known to work:
    local suitable_terminals=(
        xfce4-terminal
        konsole
        gnome-terminal
        mate-terminal
        lxterminal
        deepin-terminal
        terminator
        qterminal
        alacritty
        tilix
        termite
        xterm
        kitty
        terminology
        sakura
    )

so looks like you have xfce4 terminal installed?
pacman -Qs xfce4-term
and it uses EndeavourOS color theme…

3 Likes

something like:
System Settings → Personalisation → Applications → Default Applications → Terminal Emulator

1 Like

I had a somewhat similar issue prop up for me when I first installed EndeavourOS, but this was on Gnome. By default Gnome Terminal is the default, so all EOS tools would use that when doing any terminal stuff. However, I use Tilix terminal. So while I always used Tilix, the various EOS tools I have installed, would always open Gnome Terminal first, since it’s the DE’s default terminal. Luckily the solution was simple, simply uninstall Gnome Terminal and the system would then recognize that the only terminal I have on my system is Tilix, so any time from then on when I used the EOS tools, it would open up in Tilix and I was therefore one happy user!

You just need to determine how many terminals you have installed on your system and if you need/want all of them, and possibly if need be, uninstall any terminals applications you don’t need and then you should be good to go, so long as I understood the question correctly of course :wink:

2 Likes

No need to do there is an option in settings to change default used terminal for the eos-terminal window…

sudo nano /etc/eos-script-lib-yad.conf

The following terminals are known to work:

  1.     xfce4-terminal
    
  2.     konsole
    
  3.     gnome-terminal
    
  4.     mate-terminal
    
  5.     lxterminal
    
  6.     deepin-terminal
    
  7.     terminator
    
  8.     qterminal
    
  9.     alacritty
    
  10.     tilix
    
  11.     termite
    
  12.     xterm
    
  13.     kitty
    
  14.     terminology
    
  15.     sakura
    

sidenote: @manuel is this shown as a doc in app info tool? i can not find that…

2 Likes

Thank you ^^

you are welcome :enos: :vulcan_salute:

Terminals and their configuration is documented here:

EDIT: added a link to Welcome doc in UpdateInTerminal doc on
eos-apps-info version 1.1-5.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.