Update problem

hi, i’ve been using EOS for the last 4 months and never had a problem, now i can’t update because of hwids.


as you can see, i can’t do the default answer.

so, i tried to not replace it, however


this happened, how do i update my system? help please

lact-git now has hwdata listed as a dependency instead of hwids, so try updating lact-git first:

yay -S lact-git

2 Likes

this happen

Please follow the instructions in the forum post below:

1 Like

Please use the </> option when posting. It’s really hard to read a screen shot and it’s even tougher for someone to help you or for someone else who may have the same use to search for it once this is answered.

It’s owned by hwids. . . I just looked at both repos and aur and I don’t see that package at either location. …

Can you provide pacman -Qi hwids

Welcome to the forum @CAVIEZEL :partying_face: :tada: :balloon: :enos_flag:

Since lact-git is in the aur, I would uninstal lact-git do the update then reinstall lact-git.

4 Likes

:point_up:

This is probably what you need to do. Your AUR package is built against the old package.

That is because it was replaced by hwdata, it no longer exists.

2 Likes

@Stagger_Lee mentioned that a few posts ago already. I don’t know if it was replaced and removed, or just replaced in whatever package it was a dependency in. I just wanted to make sure removing it wouldn’t break some other random thing they installed along the way also.

Replacing a dependency won’t cause that message. That only happens when package A is a replacement for package B.

When that happens, repo packages will get their dependencies changed at the same time and get rebuilt if needed. AUR packages end up in catch-22 though. You can’t update them because you don’t yet have the new package. You can’t switch to the new package because the dependency from the AUR package stops you.

The only ways I know of to fix that problem are to temporarily remove the AUR package or tell pacman to ignore the dependencies.

If you look at pacman -Qi in this situation you need to do so with the knowledge that you are looking at the old dependencies, not the new ones. In other words, even if there was 1,000 dependencies on hwids, it isn’t definitely a problem because you are looking at the state of the packages on your system, not in the repos.

4 Likes

While I don’t disagree with anything you said, I didn’t want to advise them to remove the package to install the next to find out some obscure AUR package they do need requires it and hasn’t updated their dependencies. . . That’s all.

I think there still is the default way:

When yay/paru/trizen asks if you want to edit PKGBUILD, answer yes and edit it to change the dependency package name.

:rofl:

I wouldn’t recommend that method for a few reasons

  • It won’t work in yay because yay evaluates dependencies before the phase where you edit the PKGBUILD
  • You can’t do it as part of an update because the repo packages are updated first.
  • That means you need to do that first and it will try to pull in the new package as a dependency. However, if the old package has any repo packages dependent on it, it will still fail.
1 Like

I suppose it’s a try and see situation.
Or just uninstall… :man_shrugging:

Edit: I think it’s fixed in AUR already…

1 Like

did uninstall lact-git > update > install lact-git
i can did the update but, i don’t know if it’s a permanent fix, but for now case solved

The issue was caused by a one-time package replacement so it should be a permanent fix.

That being said, this will happen from time to time, especially if you use a lot AUR packages.

1 Like