Update Mirrors/Reflector Simple is broken after changing regional settings

Hello, I am new to Arch Linux and EndeavourOS, I’ve been using it for a week and I’ve found out that Reflector Simple or Update Mirrors on the Welcome window brakes after changing something in the regional settings in the format section, all I’ve changed was my Time Format so it can be in English and everything else is kept to the default from the installation, if I change it back to the default from the installation it works again after restart. Is it intended to do that or is it something with the config files that I have to do?
Edit: Just to clarify it just doesn’t open,no error popup, no warnings

Can you try running it from a terminal and see if you get an error displayed there?

You can open a terminal and type:

reflector-simple

I did and here is the error:
[jason@jason-systemproductname ~]$ reflector-simple
reflector-simple: info: reading file /etc/reflector-simple-tool.conf
reflector-simple: info: reading file /etc/reflector-simple.conf

(process:5228): Gtk-WARNING **: 15:28:05.584: Locale not supported by C library.
Using the fallback ‘C’ locale.
Unable to parse command line: Invalid byte sequence in conversion input
[jason@jason-systemproductname ~]$

could be an issue with the way plasma handles locale settings?
what says system wide locale settings?

locale from terminal

I also did some digging in the Arch Wiki and It could be because I don’t have en_GB locale installed
here’s what it says when I type locale in terminal:
[jason@jason-systemproductname ~]$ locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE=“en_US.UTF-8”
LC_NUMERIC=ro_RO.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE=“en_US.UTF-8”
LC_MONETARY=ro_RO.UTF-8
LC_MESSAGES=“en_US.UTF-8”
LC_PAPER=ro_RO.UTF-8
LC_NAME=ro_RO.UTF-8
LC_ADDRESS=ro_RO.UTF-8
LC_TELEPHONE=ro_RO.UTF-8
LC_MEASUREMENT=ro_RO.UTF-8
LC_IDENTIFICATION=ro_RO.UTF-8
LC_ALL=
Here’s what it says when I type locale -a on terminal:
[jason@jason-systemproductname ~]$ locale -a
C
en_US.utf8
POSIX
ro_RO.utf8

why GB? loks a bit mixed up to me with en_US

If you ask why I set it up that why I just like to have the day for example Name of Day, X Name of Month 2021 on the log in screen instead of of Name of Day Xth of Name of Month, 2021 but I’m gonna set it up as en_US and see if it works and report back
Edit: It works with en_US so it must be that I have to enable en_GB locale but I’m not sure if I have to put it the calamares at the very bottom en_GB or just remove the # from en_GB?
Edit 2: this is the line I’m talking about calamares:

Locales enabled by Calamares

en_US.UTF-8 UTF-8
ro_RO.UTF-8 UTF-8

enabling locales is done like that:

  1. edit /etc/locale.gen and uncomment the one to enable.
  2. run command locale-gen (as root)
2 Likes

Thanks for the help everyone! This worked and I got my time as en_GB now!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.